CSU 2088: Pigs can't take a sudden turn (simple computational geometry)

topic link

Pigs can’t take a sudden turn

Time limit:1000 ms Memory limit:65536 kB


Problem Descrpition

You maybe have ACed a question about computational geometry,which describes two dogs’ journey and calculate the shortest distance between them. Now, I provide a easier problem about two pigs. heir path are half-lines. When they start running, they won’t stop. Why? Because they can’t take a sudden turn.

So, I provide the start points of two pigs and their velocities. Please tell me the shortest distance between them.

We purpose that two pigs start running at the same time and will not stop because they are running in an vast grasslane without any tree.

If they smash into each other, the answer is zero and ignore the influence.

Input

The first line is an integer T which indicates the number of cases. For each case, first line is four numbers x1,y1,x2,y2, indicate the start points of two pigs(x1,y1), (x2,y2). The second line is four numbers u1,v1,u2,v2, indicate the velocities of two pigs(u1,v1),(u2,v2). T <= 1000 The absolute value of x1,y1,x2,y2,u1,v1,u2,v2 will not lager than 1000.

Output

For each case, you should output one line like ”Case i: d”. i stands for the case number and d stands for the answer, which should rounded to 6 decimal places.

Sample Input

5
1 1 2 2
1 1 2 2

1 1 2 2
1 1 -1 -1

1 1 2 2
0 1 0 -1

1 1 1 1
1 1 2 2

0 0 0 1
0 1 1 0

Sample Output

Case 1: 1.414214
Case 2: 0.000000
Case 3: 1.000000
Case 4: 0.000000
Case 5: 0.707107

meaning of the title

In the two-dimensional coordinate system, given the starting position and velocity (vector representation) of two points, find the distance when the two points are closest

Problem solving ideas

Deduce the relationship between the coordinates of two points and time from the known conditions: A(x1+v1*t, y1+u1*t), B(x2+v2*t, y2+u2*t), and then use the distance formula to get a distance The quadratic function with time, and then the problem of finding the minimum value of the quadratic function, here the opening must be upward, and it is fine to judge that a=0, that is, the speed is equal.

Code

#include <cstdio>
#include <iostream>
#include <cmath>
#define y1 YY
using namespace std;
const double eps=1e-8;
double a,b,c;
double x1,y1,u1,v1;
double x2,y2,u2,v2;
double len(double t)
{
    double ans=a*t*t+b*t+c;
    return sqrt(ans);
}

int main()
{
    int T,ca=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
        scanf("%lf%lf%lf%lf",&u1,&v1,&u2,&v2);
        c=(x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
        b=2*(x1-x2)*(u1-u2)+2*(y1-y2)*(v1-v2);
        a=(u1-u2)*(u1-u2)+(v1-v2)*(v1-v2);
        printf("Case %d: ",ca++);
        if(fabs(a)<eps)
        {
            printf("%.6f\n",len(0));
            continue;
        }
        if(-b/(a*2)<0)
        {
            printf("%.6f\n",len(0));
        }
        else
        {
            printf("%.6f\n",len(-b/(a*2)));
        }
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324655208&siteId=291194637