nyoj221 Tree binary tree preorder inorder traversal push postorder

Tree

Time Limit: 1000  ms | Memory Limit: 65535  KB
Difficulty: 3
describe
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
enter
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
sample input
DBACEGF ABCDEFG
BCAD CBAD
Sample output
ACBFGED
CDAB
Uploaded by
#include<iostream>
#include<cstring>
#include<malloc.h>
using namespace std;
typedef struct Node{
	Node * lchild,*rchild;
	char value;
}Tree;

void ReBuild(char* PreOrder,char* InOrder,int TreeLen,Tree** root)
{
	Tree *p;
	char *LeftEnd;
	if(PreOrder == NULL||InOrder == NULL||root == NULL)//检查边界条件 
	{
		return;
	}	
	p=(Tree *)malloc(sizeof(Tree));//获得前序遍历的第一个节点 
	p->value=*PreOrder;
	p->lchild=p->rchild=NULL;
	*root=p;
	if(TreeLen==1) 
	return;//一个节点直接结束 
	LeftEnd=InOrder;//LeftEnd得到先序遍历根节点的值
	while(*LeftEnd!=*PreOrder)//在中序遍历中查找该点的位置
	{
		LeftEnd++;
	}	
	//寻找左子树长度
	int LeftLen=0;
	LeftLen=(int)(LeftEnd-InOrder);
	//寻找右子树长度 
	int RightLen=0;
	RightLen=TreeLen-LeftLen-1;
	//重建左子树,递归 
	if(LeftLen>0)
		ReBuild(PreOrder+1,InOrder,LeftLen,&(p->lchild)); 
	//重建右子树,递归	
	if(RightLen>0)
		ReBuild(PreOrder+LeftLen+1,InOrder+LeftLen+1,RightLen,&(p->rchild));
}

void PostOrder(Tree *p)//二叉树建完后进行后序遍历。 
{
	if(p!=NULL)
	{
		PostOrder(p->lchild);
		PostOrder(p->rchild);
		cout<<p->value;
	}
}

int main()
{
	char a[110],b[110];
	Tree *p;
	while(cin>>a>>b)
	{
		int len=strlen(a);
		ReBuild(a,b,len,&p);
		PostOrder(p);
		cout<<endl;
	}
	return 0;
} 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324608042&siteId=291194637