poj 2184 Cow Exhibition

Cow Exhibition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15034   Accepted: 6098

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

The meaning of the question: There are n cows, each cow has an s value and an F value, select a few cows from the n cows, make the maximum value of the sum of their s value and the F value, find the maximum value, and The sums of s and F values ​​are required to be greater than 0, respectively.
Ideas: 01 Backpack, you can use one of the indicators, such as the s value, as the weight of the backpack, and the other value as the value. Because weights involve negative numbers, in order to make all weight values ​​integers, you can add a base value as a whole for translation.
AC code:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<vector>
#include<map>
#include<string>
#include<algorithm>
using namespace std;
#define N_MAX 101
#define INF 0x3f3f3f3f
int dp[N_MAX*1000*2+20];
int s[N_MAX],t[N_MAX],n;
int main() {
    while (scanf("%d",&n)!=EOF) {
        for (int i = 0; i < n; i++) {
            scanf("%d%d",&s[i],&t[i]);
       }
        int center = n * 1000;
        int range = 2 * center + 10;
        fill(dp, dp + range, -INF);
        dp[center] = 0;
        for (int i = 0; i < n;i++) {
            if (s[i] >= 0) {
                for (int j = range; j >= s[i]; j--) {
                    dp[j] = max(dp[j],dp[j-s[i]]+t[i]);
              }
            }
            else {
                for (int j = s[i]; j - s[i] < range;j++) {
                    dp[j] = max(dp[j],dp[j-s[i]]+t[i]);
                }
            }
        }
        int max_sum = -INF;
        for (int i = center; i <range;i++) {
            if (dp[i] >= 0) {
                max_sum = max(max_sum, i-center+dp[i]);
            }
        }
        if (max_sum < 0)puts("0");
        else printf("%d\n",max_sum);
    }
    return 0;

}

 

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324605447&siteId=291194637