PAT甲级-1003-Emergency-详细注释(Dijkstra模板)

PAT甲级-1003 Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
结尾无空行

Sample Output:

2 4
结尾无空行

题目大意:

给一个图给定起点和终点需要找到,从起点到终点最短路的条数,同时每个点有点权需要找到到终点最大的点权

思路:

很经典的Dijkstra算法,注释很详细,供以后复习使用

#include <bits/stdc++.h>
using namespace std;
const int maxn=505;
const int inf=0x7fffffff;
int n,m,st,ed,g[maxn][maxn],weight[maxn];//g存图,weight存救援队的数量 
int d[maxn],w[maxn]={},num[maxn]={};//d为最短路径距离,w为记录最大救援人数之和,num为记录最短路径条数 
bool vis[maxn]={false};
void dij(int s){
	fill(d,d+maxn,inf);
	d[s]=0;
	w[s]=weight[s];
	num[s]=1;
	for(int i=0;i<n;i++){
		int u=-1,min=inf;
		for(int j=0;j<n;j++){
			if(!vis[j]&&d[j]<min){//如果是未被访问过的点且在所有可访问的里面距离最短 
				u=j;
				min=d[j];
			}
		}if(u==-1)return;
		vis[u]=true;
		for(int v=0;v<n;v++){
			if(!vis[v]&&g[u][v]!=inf){//从起点到该点可达且未被访问过 
				if(d[u]+g[u][v]<d[v]){//若经过该点可以缩短被访问点距离 
					d[v]=d[u]+g[u][v];
					w[v]=w[u]+weight[v];
					num[v]=num[u];
				}else if(d[u]+g[u][v]==d[v]){//若长度相同
				if(w[u]+weight[v]>w[v]){//累积团队更多 
				w[v]=w[u]+weight[v];
				}num[v]+=num[u];//该相同路径上点最短路在原来基础上相加 
			}
		}
	}
}
}
int main(){
	cin>>n>>m>>st>>ed;
	for(int i=0;i<n;i++){
		cin>>weight[i];
	}
	int u,v;
	fill(g[0],g[0]+maxn*maxn,inf);
	for(int i=0;i<m;i++){
		cin>>u>>v;
		cin>>g[u][v];
		g[v][u]=g[u][v];
	}
	dij(st);
	cout<<num[ed]<<" "<<w[ed];
	return 0;
}

Guess you like

Origin blog.csdn.net/qq_48642405/article/details/121872748