HDU-1312题解

题目描述

据说翻译是个好东西(这句与题目无关?)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

1
2
3
4
45
59
6
13

解题思路

一道深搜水题 嗯我就是来水题解的

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
#include <iostream>
#include <string>

using namespace std;
char map[22][22];
int n, m;
int result = 1;
int x, y;


void dfs(int a, int b) {
map[a][b] = '#';
result++;
if (a - 1 > 0 && map[a - 1][b] == '.') {
dfs(a - 1, b);
}
if (a + 1 <= n && map[a + 1][b] == '.') {
dfs(a + 1, b);
}
if (b - 1 > 0 && map[a][b - 1] == '.') {
dfs(a, b - 1);
}
if (b + 1 <= m && map[a][b + 1] == '.') {
dfs(a, b + 1);
}
}

int main() {
while (cin >> m >> n) {
if (n == 0 && m == 0) break;

for (int i = 1; i <= n; ++i) {
for (int j = 1; j <= m; ++j) {
char s;
cin >> s;
if (s == '@') {
x = i; y = j;
}
map[i][j] = s;
}
}

map[x][y] = '#';
if (x-1 > 0 && map[x - 1][y] == '.') {
dfs(x - 1, y);
}
if (x + 1 <= n && map[x + 1][y] == '.') {
dfs(x + 1, y);
}
if (y - 1 > 0 && map[x][y - 1] == '.') {
dfs(x, y - 1);
}
if (y + 1 <= m && map[x][y + 1] == '.') {
dfs(x, y + 1);
}
cout << result << endl;
result = 1;
}

return 0;
}

Guess you like

Origin blog.csdn.net/cpongo11/article/details/100071867