1043 输出PATest (C++)

给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

结尾无空行

输出样例:

PATestPATestPTetPTePePee

结尾无空行

代码:

#include <iostream>
#include<string>
using namespace std;
int main() {
	string str;
	cin >> str;
	int a[200] = { 0 };
	int i;
	for (i = 0;i < str.size();i++) {
		a[str[i]]++;
	}
	while (a['P'] > 0|| a['A'] > 0|| a['T'] > 0|| a['e'] > 0|| a['s'] > 0|| a['t'] > 0) 
	{
		if (a['P'] > 0) { cout << "P"; a['P']--; }
		if (a['A'] > 0) { cout << "A"; a['A']--; }
		if (a['T'] > 0) { cout << "T"; a['T']--; }
		if (a['e'] > 0) { cout << "e"; a['e']--; }
		if (a['s'] > 0) { cout << "s"; a['s']--; }
		if (a['t'] > 0) { cout << "t"; a['t']--; }
	}
	return 0;
}

Guess you like

Origin blog.csdn.net/qq_40748967/article/details/121212205