OJ Problem 3438 c# calculate the area of a rectangle (inheritance problem)

Title description

According to the given code, fill in the missing code, enter two numbers as the length and width of the rectangle to get the area of ​​the rectangle. 

using System;
namespace InheritanceApplication
{    class Shape     {       public void setWidth(int w)       {          width = w;       }       public void setHeight(int h)       {          height = h;       }       protected int width;       protected int height;    } /***** ***********/  Write the code here, and only submit the code here  /****************/    class RectangleTester    {       static void Main(string[ ] args)       {          Rectangle Rect = new Rectangle();
















   





        int width = int.Parse(Console.ReadLine());
          int height =int.Parse(Console.ReadLine());
         Rect.setWidth(width);
         Rect.setHeight(height);
         Console.WriteLine("总面积: {0}",  Rect.getArea());
         Console.ReadKey();
      }
   }
}
 

enter

3 5

Output

15

Sample input

 

5
7

Sample output

35
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Security.Cryptography;
using System.IO;
namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            Rectangle Rect = new Rectangle();
            int width = int.Parse(Console.ReadLine());
            int height = int.Parse(Console.ReadLine());
            Rect.setWidth(width);
            Rect.setHeight(height);
            Console.WriteLine("总面积: {0}", Rect.getArea());
            Console.ReadKey();
        }
    }
    class Shape
    {
        public void setWidth(int w)
        {
            width = w;
        }
        public void setHeight(int h)
        {
            height = h;
        }
        protected int width;
        protected int height;
    }
    class Rectangle:Shape
    {
        public int getArea()
        {
            return width * height;
        }
    }
} 

 

Guess you like

Origin blog.csdn.net/wangws_sb/article/details/105113624