‎Networking (prim algorithm)

 ‎Networking (prim algorithm)

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

Sponsor

 Ideas:

Proper minimum spanning tree problem, solved by prim algorithm

Implementation code:

 

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

int inf=0x3f3f3f;
int map[100][100],dis[100],book[100];
int m,n;

int prim()
{
	int i,j,k,sum=0,u,min;
	
	for(i=1;i<=n;i++)//循环范围根据题目从1开始 ,这里初始化一下 
	{
		dis[i]=map[1][i];//表示原点到其他点的距离 
		book[i]=0;
	}
	book[1]=1;
	//dis[1]=0;
	
	for(i=1;i<n;i++)
	{
		min=inf;
		for(j=1;j<=n;j++)
		{
			if(book[j]==0&&min>dis[j])
			{
				min=dis[j];
				u=j;
			}
		}
		book[u]=1;
		sum+=dis[u];
		
		for(j=1;j<=n;j++)
		{
			if(book[j]==0&&dis[j]>map[u][j])
			dis[j]=map[u][j];
		}
	}
	return sum;
}

int main()
{
	int a,b,c,i,j,k;
	
	while(scanf("%d",&n),n!=0)
	{
		memset(map,inf,sizeof(map));//初始化一下 
		scanf("%d",&m);
		for(i=1;i<=m;i++)//输入地图 
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c||map[b][a]>c)
			{
				map[a][b]=map[b][a]=c;
			}
		}
		
		printf("%d\n",prim());
	}
	return 0;
}

note:

If there is a smaller distance between the same two points entered in the input, we need to update the input map

For the ignorant, you can look at this first: https://blog.csdn.net/with_wine/article/details/113972924 lay the foundation

Guess you like

Origin blog.csdn.net/with_wine/article/details/114548338