Advanced Level 1001 A+B Format (20 point(s))

topic

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification::

Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 ⩽ a , b ⩽ 1 0 6 -10^6\leqslant a,b\leqslant 10^6 106a,b106​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

Thinking analysis:

Use the to_string function of the string class to convert the int type to the string type

Code:

#include <iostream>
using namespace std;
int main(){
    
    
    int  a, b;
    cin >> a >> b;
    string s = to_string(a + b), res;
    for(int i = s.size() - 1, j = 1; i >= 0; i--, j++){
    
    
        res = s[i] + res;
        if(j % 3 == 0 && i && s[i - 1] != '-') res = "," + res;
    }
    cout << res << endl;
}

PAT_Advanced_Level

Guess you like

Origin blog.csdn.net/zy440458/article/details/113852081