G - Seek the Name, Seek the Fame(kmp)

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Input a string s, find the length of the string that is both the prefix of s and the suffix of s, and output from small to large

Note that the length n of s must satisfy the condition

Knowing that the length n of s is the largest length, Next[n] is the second largest length of s, Next[Next[n]] is the third largest length... and so on, until the next value of traversed is 0 , Indicating that there is no smaller length

You can put these numbers into a stack, and then pop them out one by one.

#include <cstdio>
#include <iostream>
#include <cstring>
#include <stack>
using namespace std;
const int N = 1e6 + 5; 

char a[N], b[N];
int Next[N], f[N]; // Next是字符串 a 和自己匹配,f是字符串 a 和 b 匹配 
int n, m;
// 求解 Next 数组
void get_next()
{
    
    
	Next[1] = 0;
	for (int i = 2, j = 0; i <= n; i++) {
    
    
		while (j > 0 && a[i] != a[j + 1]) j = Next[j];
		if (a[i] == a[j + 1]) j++;
		Next[i] = j;
	}
}

int main(void)
{
    
    
	stack<int> stk;
	while (scanf("%s", a + 1) != EOF) {
    
    
		n = strlen(a + 1);
		get_next();
		stk.push(n);
		while (Next[n] != 0) {
    
    
			stk.push(Next[n]);
			n = Next[n];
		}
		while (stk.size()) {
    
    
			cout << stk.top() << " ";
			stk.pop();
		}
		cout << endl;
	}
	
	return 0;
}

Guess you like

Origin blog.csdn.net/weixin_43772166/article/details/108782141