POJ 1024 Gone Fishing (greedy)

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,…,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0

Sample Output

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724

Ideas

In the end, it takes different time to go to different positions, and it is possible that more fish will be obtained in the following positions. All enumerate every end position. First use the total time to subtract the time spent in each position before the end point, and the rest is the time that can be used for fishing. Add the number of the lake and the number of fish that can be caught in the current unit time in the lake into a priority queue sorted by the number of fish. When the fishing time is not up to the total time, each time the first element of the queue is taken out, the number of fish is accumulated, the corresponding value of each fish pond fishing time array is recorded plus 1, and the number of continuous hangings in the lake is updated and added to the queue in. Cycle until time runs out. Finally, compare the total number of fishing, if it is greater than the previous answer, update it.

Code

#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;

int f[30];							//第一个单位时间钓到的鱼的数量 
int d[30];							//后面每次减少的数量 
int t[30];							//从第i-1个鱼塘到第i个鱼塘的时间 
int maxlaketime[30];				//钓鱼总数最大时,在每个鱼塘停留的时间 
int nowlaketime[30];				//枚举过程中,在每个鱼塘停留的时间 

struct lake							//lake对应的是一个鱼塘状态   同一个鱼塘不同时间钓到不同数量的鱼 
{
    
    
	int i,n;						//i 鱼塘编号  n 当前在该鱼塘可钓到的鱼的数量 
	friend bool operator < (const lake a,const lake b)
	{
    
    
		if(a.n==b.n)
			return a.i>b.i;			//按当前状态钓到的鱼数从大到小排序 
		return a.n<b.n;				//相等则按序号排 
	}
};

int main()
{
    
    
	int n;
	while(1)
	{
    
    
		cin>>n;
		if(n==0)
			return 0;
		int h;
		cin>>h;
		for(int i=1;i<=n;i++)
			cin>>f[i];
		for(int i=1;i<=n;i++)
			cin>>d[i];
		for(int i=2;i<=n;i++)
			cin>>t[i];
		int maxfish=-1;
		for(int i=1;i<=n;i++)			//枚举终点位置 
		{
    
    	
			int nowfish=0;				//重置数据 
			memset(nowlaketime,0,sizeof(nowlaketime));
			int fishtime=h*12;			//时间转换 
			for(int j=2;j<=i;j++)
				fishtime-=t[j];			//减去路上的时间 
			priority_queue<lake>q;		//优先队列 
			for(int j=1;j<=i;j++)
			{
    
    
				lake tmp;
				tmp.i=j;
				tmp.n=f[j];
				q.push(tmp);			//将鱼塘的初始状态加入队列 
			}
			for(int j=1;j<=fishtime;j++)
			{
    
    
				lake tmp=q.top();		//首元素 
				q.pop();
				nowlaketime[tmp.i]++;	//对应鱼塘的时间加1 
				nowfish+=tmp.n;			//累计鱼的数量 
				tmp.n-=d[tmp.i];		//该鱼塘状态更新 
				if(tmp.n<0)
					tmp.n=0;			//小于0 
				q.push(tmp);			//重新加入队列 
			}
			if(nowfish>maxfish)			//大于答案,更新答案 
			{
    
    
				maxfish=nowfish;
				memcpy(maxlaketime,nowlaketime,sizeof(nowlaketime));
			}
			if(nowfish==maxfish)		//相等,则比较顺序 
			{
    
    
				for(int j=1;j<=n;j++)
					if(maxlaketime[j]<nowlaketime[j])
					{
    
    
						memcpy(maxlaketime,nowlaketime,sizeof(nowlaketime));
						break;
					}
					else if(maxlaketime[j]>nowlaketime[j])
						break;
			}
		}
		for(int i=1;i<n;i++)			//按格式输出 
			cout<<maxlaketime[i]*5<<", ";	
		cout<<maxlaketime[n]*5<<endl;
		cout<<"Number of fish expected: "<<maxfish<<endl<<endl;	// 注意两个换行 
	}
}

Guess you like

Origin blog.csdn.net/m0_54621932/article/details/113925567