Line segment tree-Balanced Lineup

Total time limit: 5000ms

Single test point time limit: 2000ms

Memory limit: 65536kB

description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

enter

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample output

6
3
0
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAXN = 50005;
const int INF = 0x7fffffff;
int N, Q;

struct node {
    int L, R;
    int maxv, minv;
};

node tree[4*MAXN];

void build_tree(int root, int L, int R)
{
    tree[root].L = L;
    tree[root].R = R;
    tree[root].maxv = -INF;
    tree[root].minv = INF;

    if (L == R)
        return;

    int mid = (L+R)/2;
    build_tree(root*2+1, L, mid);
    build_tree(root*2+2, mid+1, R);
}

void insert(int root, int i, int v)
{
    node& rt = tree[root];
    rt.maxv = max(rt.maxv, v);
    rt.minv = min(rt.minv, v);

    if (rt.L == rt.R)
        return ;

    int mid = (rt.L + rt.R) / 2;
    if (i <= mid) 
        insert(2*root+1, i, v);
    else
        insert(2*root+2, i, v);
}

/* 
 * set maxV and minV before calling this function!!!
 */
int maxV, minV;
void query(int root, int L, int R)
{
    node& rt = tree[root];

    if (L == rt.L && R == rt.R) {
        maxV = max(maxV, rt.maxv);
        minV = min(minV, rt.minv);
        return;
    }

    int mid = (rt.L + rt.R) / 2;
    if (R <= mid)
        query(root*2+1, L, R);
    else if (L >= mid + 1)
        query(root*2+2, L, R);
    else {
        query(root*2+1, L, mid);
        query(root*2+2, mid+1, R);
    }
}


int main()
{
    scanf("%d%d", &N, &Q);
    build_tree(0, 0, N-1);

    for (int i = 0; i < N; ++i) {
        int t;
        scanf("%d", &t);
        insert(0, i, t);
    }

    for (int i = 0; i < Q; ++i) {
        int l, r;
        scanf("%d%d", &l, &r);
        minV = INF;
        maxV = -INF;
        query(0, l-1, r-1);
        printf("%d\n", maxV - minV);
    }

    return 0;
}

 

Guess you like

Origin blog.csdn.net/w112348/article/details/109034595