Common Subsequene POJ 1458 LCS longest common subsequence problem, winter vacation training

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
Very basic lcs problem, here I In the lcs practice of putting a three string,
two string problem solution

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
#include <stack>
#include <set>
#include <queue>
#include <vector>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;
char s1[1000];
char s2[1000];
int dp[1000][1000];
int main()
{
    
    
    while(scanf("%s%s",s1+1,s2+1)!=EOF){
    
    
    int len1 = strlen(s1+1);
    int len2 = strlen(s2+1);
    for(int i=1;i<=len1;i++)
    {
    
    
        for(int j=1;j<=len2;j++)
        {
    
    
            if(s1[i] == s2[j]) dp[i][j] = dp[i-1][j-1] + 1;
            else dp[i][j] = max(dp[i-1][j],max(dp[i-1][j-1],dp[i][j-1]));
        }
    }
    cout<<dp[len1][len2]<<endl;
    }
    return 0;
}

Three string templates

void solve(){
    
    //三子串lcs问题
    int dp[110][110][110];
    string s1,s2,s3;
    cin>>s1>>s2>>s3;
    int n1=s1.size();
    int n2=s2.size();
    int n3=s3.size();
    for(int i=0;i<=n1;i++){
    
    
        for(int j=0;j<=n2;j++){
    
    
            for(int k=0;k<=n3;k++){
    
    
                if(i==0||j==0||k==0)
                    dp[i][j][k]=0;
            }
        }
    }
    for(int i=1;i<=n1;i++){
    
    
        for(int j=1;j<=n2;j++){
    
    
            for(int k=1;k<=n3;k++){
    
    
                if(s1[i-1]==s2[j-1]&&s2[j-1]==s3[k-1])
                    dp[i][j][k]=dp[i-1][j-1][k-1]+1;
                else
                    dp[i][j][k]=max(max(dp[i-1][j][k],dp[i][j-1][k]),dp[i][j][k-1]);
            }
        }
    }
    cout<<dp[n1][n2][n3]<<endl;
}

Guess you like

Origin blog.csdn.net/qq_45891413/article/details/112998098