One question to get the application of MAP: 1022 Digital Library (30 points)

1 Question content:

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

input

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104 ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

output

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

2 question meaning analysis

The query function of analog digital library. It will give information about n books and m commands that need to be queried. The number label corresponds to the corresponding command. The string after the number number is the search term for the query. It is required to output this command and output the book that meets the conditions. did, if none of them are found, output Not Found

Triple point attention

  1. When outputting, it should be noted that did is a fixed 7-digit number, if there is no 7-digit number, zero should be added.
  2. The keyword column needs to continue to divide the mark according to the space
  3. Pay attention to the newline characters, the input problems caused by the need to use getchar to eliminate
  4. It is mp<string ,set>more convenient and quicker to use the way to mark
#include <cstdio>
#include <iostream>
#include <map>
#include <string>
#include <set>
using namespace std;
const int mmax = 10010; 
map<string,set<int>> blab;
string temp;
int n,m,bid;
int main(){
    
    
	scanf("%d",&n);
	for(int i=0;i<n;i++){
    
    
		scanf("%d",&bid);
		char c = getchar();
		for(int j=1;j<=5;j++){
    
    
			getline(cin,temp);
			if(j==3){
    
    
				int k;string tt;
				while(temp.size()){
    
    
					k = 0;
					while(temp[k]!=' '&&k!=temp.size()){
    
    
						tt += temp[k];
						k++;
					}
					blab[tt].insert(bid);
					tt = "";
					temp.erase(0,k+1);
				}
			}else{
    
    
				blab[temp].insert(bid);
			}			
		}
	}
	scanf("%d",&m);
	char c = getchar();
	string num;
	for(int i=0;i<m;i++){
    
    
		getline(cin,temp);
		cout<<temp<<endl;
		temp = temp.erase(0,3);
		int len = blab[temp].size();
		if(len){
    
    
			for(set<int>::iterator it = blab[temp].begin();it!=blab[temp].end();it++) 
			printf("%07d\n",*it);
		}else{
    
    
			cout<<"Not Found"<<endl;
		}
	}	
	return  0;
}

4 Knowledge supplement map

In the header file ==<map>==:

4.1 How to understand the mapping in map:

  • Equivalent to array[0] = 5.20, which maps the int type to the double type.
  • map can map any basic type (including STL container) to any basic type (including STL container).

4.2 How to define map:

  • The mapping from string to integer: map<string,int> mp; The string must only be represented by string.
  • Character type to integer type mapping: map<char,int> mp;
  • The mapping from set container to string type: map<string,set<int>> mp; can represent mp["paopap"] = {11,12,15,16,17}, and the values ​​inside cannot be the same, follow Arrange in ascending order. Specific examples can be seen:

4.3 Map access:

  1. Access by subscript:
map<char,int> mp;
mp['c'] = 20;
mp['c'] = 30printf("%d\n",mp['c']); // 结果为30
  1. Access via iterator
for(auto it = j.begin(); it!= m.end();it++){
    
    
	cout<< it->fist<<" "<< it->second << endl;
}
// 访问map的第⼀个元素,输出它的键和值
cout << m.begin()->first << " " << m.begin()->second << endl;
// 访问map的最后⼀个元素,输出它的键和值
cout << m.rbegin()->first << " " << m.rbegin()->second << endl;
// 输出map的元素个数
cout << m.size() << endl;

4.4Map commonly used functions:

  1. find()
    find(key) returns an iterator of the map whose key is the key. The time complexity is O(log~N), and N is the number of maps in the map.
  2. erase()
    delete a single element: mp.erase(it) // it is an iterator; mp.erase('b')
    delete all elements in an interval: mp.erase(first,last) //
  3. size() get the logarithm of map mapping
  4. clear() clear the map
map<char,int> mp;
mp['a'] = 1;
map <char,int> mp;
int main(){
    
    
	mp['a'] = 1;
	mp['b'] = 2;
	auto it = mp.find('a'); //auto 可以让编译器根据初始值类型直接推断变量的类型
	printf("%c %d\n",it->first,it->second);
	mp.erase(it,mp.end());//删除it之后的所有映射。
	mp.erase(it) //就把mp['a']删除了
	mp.clear();
}

4.5 Common uses:

  1. Need to establish the problem of mapping between characters (or strings) and integers, using map can reduce the amount of code.
  2. To determine the existence of large integers or other types of data, you can use map as a bool array
  3. The mapping of strings and strings may also be encountered.
    叮叮~具体应用可以参考本人写的文章:: PAT1018

Encourage
Come onヾ(◍°∇°◍)ノ゙

If you think my article is helpful and inspiring for you, please give me an encouragement (づ ̄3 ̄)づ╭❤
Follow me and join 共勉加油me!
If there are errors in the article, please feel free to advise!

Guess you like

Origin blog.csdn.net/qq_43992949/article/details/107153114