【Digital dp + like pressure】 XHXJ's LIS

topic

define xhxj (Xin Hang senior sister(学姐)) If you do not know xhxj, then carefully reading the entire description is very important. 
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu. 
Like many god cattles, xhxj has a legendary life: 2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final. As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type. 
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls. Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time. For the first one to solve this problem,xhxj will upgrade 20 favorability rate。

Input

First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.( 0<L<=R<2 63-1 and 1<=K<=10).

Output

For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.

Sample Input

1
123 321 2

Sample Output

Case #1: 139

analysis

The approximate meaning of the title is to let you count the number of numbers that meet the requirements within a given interval. A number if its longest ascending subsequence length of each digit is k, then it meets the requirements. This question is divided into three points.
1. First of all, this question is consistent with interval subtraction. We only need to ask for the number of legal numbers 0 ~ l-1 and 0 ~ r, and then do the subtraction. 2. The processing of LIS We use state compression to deal with LIS pressure: the position of the i-th 1 in the binary of this number represents the minimum value of the last bit of the LIS with the current sequence length i So the number of 1s is the length status update of LIS : Suppose the current status is 0100100110, the longest sequence is 1 4 7 8, if our next dp bit value is 6, then the rising subsequence of length 3 is changed from the original 1 4 7 becomes 1 4 6. Correspondingly, our updated state is 0100101010, which is equivalent to 6 replacing 7 in binary. Then the deep search is over again. 


Code

#include <bits/stdc++.h>
using namespace std;
long long dp[25][1<<10][11];
int k,bit[25];
int ne(int x,int s){
    for (int i=x;i<10;++i)
    if (s&1<<i) return (s^(1<<i)|(1<<x));
    return s|(1<<x);
}
int num(int s){
    int ret=0;
    while (s){
        if (s&1)
        ret ++ ;
        s>>=1;
    }
    return right;
}
long long dfs (int pos,int s,bool e,bool z){
    if (pos==-1) return num(s)==k;
    if (!e&&dp[pos][s][k]!=-1) return dp[pos][s][k];
    long long ans=0;
    int endd=e?bit[pos]:9;
    for (int i=0;i<=endd;++i)
    ans+=dfs(pos-1,(z&&i==0)?0:ne(i,s),e&&i==endd,z&&(i==0));
    if (!e) dp[pos][s][k]=ans;
    return ans;
}
long long ca(long long n){
    int len=0;
    while (n){
        bit[len++]=n%10;
        n/=10;
    }
    return dfs(len-1,0,1,1);
}
int main(){
    int t;
    long long l,r;
    memset(dp,-1,sizeof dp);
    scanf("%d",&t);
    int casee=0;
    while (t--){
        scanf("%I64d%I64d%d",&l,&r,&k);
        printf("Case #%d: ",++casee);
        printf("%I64d\n",ca(r)-ca(l-1));
    }
    return 0;
}

 

Guess you like

Origin www.cnblogs.com/Vocanda/p/12753323.html