C ++ exercises complex number class-overloaded operator +

  Description
  
  defines a complex class Complex, overloading the operator "+", so that it can be used for the addition of complex numbers. Overload operator functions as ordinary functions that are not members or friends. Write a program to find the sum of two complex numbers.
  
  Input
  
  of two complex numbers
  
  Output
  
  complex number and
  
  the Sample Input
  
  . 3. 4
  
  . 5 -10
  
  the Sample Output
  
  (8.00, -6.00i)
  
  #include <the iostream>
  
  #include <The iomanip>
  
  the using namespace STD;
  
  class Complex
  
  {
  
  public:
  
  Complex ();
  
  Complex (Double r, double i);
  
  double get_real ();
  
  double get_imag ();
  
  void display ();
  
  private:
  
  double real;
  
  double imag;
  
  };
  
  Complex :: Complex ()
  
  {
  
  return;
  
  }
  
  Complex::Complex(double r,double i)
  
  {
  
  real=r;imag=i;
  
  }
  
  double Complex::get_real()
  
  {
  
  return real;
  
  }
  
  double Complex::get_imag()
  
  {
  
  return imag;
  
  }
  
  void Complex::display()
  
  {
  
  cout<<"("<<real<<","<<imag<<"i)"<<endl;
  
  }
  
  Complex operator +(Complex a,Complex b)
  
  {
  
  double i,j;
  
  i=a.get_real() +b.get_real();
  
  j=a.get_imag() +b.get_imag();
  
  Complex c(i,j);
  
  return c;
  
  }
  
  int main()
  
  {
  
  double real,imag;
  
  cin>>real>>imag;
  
  Complex c1(real,image);
  
  cin>>real>>imag;
  
  Complex c2(real,imag);
  
  Complex c3=c1+c2;
  
  cout<<setiosflags(ios::fixed);
  
  cout<<setprecision(2);
  
  c3.display();
  
  return 0;
  
  }

  Description
  
  defines a complex class Complex, overloading the operator "+", so that it can be used for the addition of complex numbers. The two calculations involved in the calculation can be class objects, or one of them can be an integer in any order. For example, c1 + c2, i + c1, c1 + i are all legal (let i be an integer, c1, c2 are complex numbers). Write a program to find the sum of two complex numbers, the sum of integers and complex numbers.
  
  Input
  
  Two complex numbers
  
  a complex number and an integer
  
  an integer and a complex number
  
  Output The sum of
  
  two complex numbers, the sum of complex numbers and integers, the sum of integers and complex numbers.
  
  Sample Input
  
  3 4 5 -10
  
  3 4 5
  
  5 3 4
  
  Sample Output
  
  c1 + c2 = (8.00, -6.00i)
  
  c1 + i = (8.00,4.00i)
  
  i + c1 = (8.00,4.00i)
  
  #include <iostream >
  
  #include <iomanip>
  
  using namespace std;
  
  class Complex
  
  {
  
  public:
  
  Complex ()
  
  {
  
  real = 0;
  
  imag = 0;
  
  }
  
  Complex (double r, double i)
  
  {
  
  real=r;
  
  imag=i;
  
  }
  
  Complex operator+(Complex &c2);
  
  Complex operator+(int &i);
  
  friend Complex operator+(int&,Complex &);
  
  void display();
  
  private:
  
  double real;
  
  double imag;
  
  };
  
  Complex Complex:: operator+(Complex &c2)
  
  {return Complex(real+c2.real,imag+c2.imag);}
  
  Complex Complex:: operator+(int &i)
  
  {return Complex(real+i,imag);}
  
  Complex operator+(int&i,Complex &c)
  
  {return Complex(i+c.real,c.imag);}
  
  void Complex::display()
  
  { cout<<"("<<real<<","<<imag<<"i)"<<endl;}
  
  int main()
  
  {
  
  double real,imag;
  
  cin>>real>>imag;
  
  Complex c1(real,imag);
  
  cin>>real>>imag;
  
  Complex c2(real,imag);
  
  cout<<setiosflags(ios::fixed);
  
  cout<<setprecision(2);
  
  Complex c3=c1+c2;
  
  cout<<"c1+c2=";
  
  c3.display();
  
  int i;
  
  cin>>real>>imag;
  
  cin>>i;
  
  c3=Complex(real,imag)+i;
  
  cout<<"c1+i=";
  
  c3.display();
  
  cin>>i;
  
  cin>>real>>imag;
  
  c1=Complex(real,imag);
  
  c3=i+c1;
  
  cout<<"i+c1=";
  
  c3.display();
  
  return 0;
  
  }

Guess you like

Origin www.cnblogs.com/zhenhua1618/p/12729821.html