Building Shops HDU-6024 (dynamic planning)

HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
Output
For each test case, print a single line containing an integer, denoting the minimal cost.
Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
Sample Output
5
11
Topic: There are n locations where it is possible to build a candy store. The leftmost location must be a candy store. If the latter position is a candy store, the cost is the cost of building a candy store. Shop, the cost is the distance to the candy store closest to it on the left. Ask what the minimum cost is.
Idea: Whether or not a candy store is currently established is post-effect on the results, so dynamic programming needs to be considered. If it is currently necessary to establish a confectionery store, then the smallest one is the cost of establishing a confectionery store at the previous point. If you don't need to build a candy store, just find a point to build a candy store in front, plus the distance cost.
Insert picture description here
As shown in the figure: If 4 does not build a candy store, it now finds 1, 1 is a candy store. What about distance? We can find that the distance of 1-2 is calculated 3 times, 2-3 is twice, and 3-4 is once. The frequency is 4-1, 4-2, 4-3. The rule is obvious.
State transfer equation: the
Insert picture description here
code is as follows:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=3e3+100;
struct node{
	int x;ll val;
	bool operator<(const node &a)const{
		return x<a.x;
	}
}p[maxx];
ll dp[maxx][2];
int n;

int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++) scanf("%d%lld",&p[i].x,&p[i].val);
		memset(dp,inf,sizeof(dp));
		sort(p+1,p+1+n);
		dp[1][1]=p[1].val;
		dp[1][0]=inf;
		for(int i=2;i<=n;i++)
		{
			dp[i][1]=min(dp[i-1][1],dp[i-1][0])+p[i].val;
			ll dis=0;
			for(int j=i-1;j>=1;j--)
			{
				dis=dis+(ll)(i-j)*(p[j+1].x-p[j].x);//这里一定要用long long。
				dp[i][0]=min(dp[i][0],dp[j][1]+dis);
			}
		}
		printf("%lld\n",min(dp[n][1],dp[n][0]));
	}
	return 0;
}

Come on a hard, ( o ) / ~

Published 652 original articles · won 101 · views 50,000+

Guess you like

Origin blog.csdn.net/starlet_kiss/article/details/105447494