POJ_Prob.ID:2386 Lake Counting

Lake Counting

Time Limit: 1000MS Memory Limit: 65536K

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: The number of ponds in Farmer John’s field.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Solution of source code

#include<stdio.h>
#include<iostream>



#define MAX_N 1000

//#define MAX_M 1000;
using namespace std;
int N,M;   
char field[MAX_N][MAX_N];
void dfs(int x, int y){
	field[x][y]='.';
	for (int dx=-1;dx<=1;dx++){
		for(int dy=-1;dy<=1;dy++){
			int nx=x+dx,ny=y+dy;
			if(0<=nx&&nx<N&&0<=ny&&ny<M&&field[nx][ny]=='W') dfs(nx,ny);
			 
		}
	}
	return;
	
}

int main(){
	int res=0;
	scanf("%d %d",&N,&M);

	for(int i=0;i<N;i++){
		for(int j=0;j<M;j++){
			cin>>field[i][j];
		}
	}
	
	for (int i=0;i<N;i++){
		for(int j=0;j<M;j++){
			if(field[i][j]=='W'){
			
			dfs(i,j);
			
			res++;
		}
	}
}
 
printf("%d\n",res);
}
Released nine original articles · won praise 13 · views 9515

Guess you like

Origin blog.csdn.net/ABV09876543210/article/details/104286031