PAT A1085 Perfect Sequence (25分)

Topic links : https://pintia.cn/problem-sets/994805342720868352/problems/994805381845336064

题目描述
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

输入
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10^​5​​ ) is the number of integers in the sequence, and p (≤10^​9​​ ) is the parameter. In the second line there are N positive integers, each is no greater than 10^​9​​ .

输出
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample input
10. 8
2 20 is. 4. 3. 1. 5. 6. 7. 8. 9

Sample output
8

Code

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int n, p, a[maxn];

int main() {
	scanf("%d%d", &n, &p);
	for(int i = 0; i < n; i++)
		scanf("%d", &a[i]);
	sort(a, a + n);
	int ans = 1;
	for(int i = 0; i < n; i++) {
		int j = upper_bound(a + i + 1, a + n, (long long)a[i] * p) - a;
		ans = max(ans, j - i);
	}
	printf("%d\n", ans);
	return 0;
}
Published 288 original articles · won praise 12 · views 20000 +

Guess you like

Origin blog.csdn.net/Rhao999/article/details/104748931