PAT A1008 Elevator (20 minutes)

Topic links : https://pintia.cn/problem-sets/994805342720868352/problems/994805511923286016

题目描述
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

输入
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

输出
For each test case, print the total time on a single line.

Sample input
3231

Sample Output
41

Code

#include <cstdio>

int main() {
	int n, a[101], ans = 0;
	a[0] = 0;
	scanf("%d", &n);
	for(int i = 1; i <= n; i++) {
		scanf("%d", &a[i]);
		if(a[i] > a[i - 1])
			ans = ans + (a[i] - a[i - 1]) * 6 + 5;
		else if(a[i] < a[i - 1])
			ans = ans + (a[i - 1] - a[i]) * 4 + 5;
        else
            ans += 5;		//层数相同也要停留5秒!
	}
	printf("%d\n", ans);
	return 0;
}
Published 288 original articles · won praise 12 · views 20000 +

Guess you like

Origin blog.csdn.net/Rhao999/article/details/104918885