PAT A1081 Rational Sum (20分)

Topic links : https://pintia.cn/problem-sets/994805342720868352/problems/994805386161274880

题目描述
Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

输入
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

输出
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample input
5
2/5 8/3 4/15 1/30 -2/60

Sample output
3 1/3

Code

#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;

struct fraction {
	ll up, down;
};

ll gcd(ll a, ll b) {
	return b == 0 ? a : gcd(b, a % b);
}

fraction reduction(fraction result) {
	if(result.down < 0) {
		result.up = -result.up;
		result.down = -result.down;
	}
	if(result.up == 0)
		result.down = 1;
	else {
		int d = gcd(abs(result.up), abs(result.down));
		result.up /= d;
		result.down /= d;
	}
	return result;
}

fraction add (fraction f1, fraction f2) {
	fraction result;
	result.up = f1.up * f2.down + f2.up * f1.down;
	result.down = f1.down * f2.down;
	return reduction(result);
}

void showResult(fraction r) {
	//reduction(r);	
	if(r.down == 1)
		printf("%lld\n", r.up);
	else if(abs(r.up) > r.down) {
		printf("%lld %lld/%lld\n", r.up / r.down, abs(r.up) % r.down, r.down);
	}
	else {
		printf("%lld/%lld\n", r.up, r.down);
	}
}

int main() {
	int n;
	scanf("%d", &n);
	fraction sum, temp;
	sum.up = 0, sum.down = 1;
	for(int i = 0; i < n; i++) {
		scanf("%lld/%lld", &temp.up, &temp.down);
		sum = add(sum, temp);
	}
	showResult(sum);
	return 0;
}
Published 288 original articles · won praise 12 · views 20000 +

Guess you like

Origin blog.csdn.net/Rhao999/article/details/104979939