Robot

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.

Input

There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.

Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.

Sample Input

3
2 1
3 3
4 2
0

Sample Output

2 1
3 2
4 2

lower_bound(key_value) ,返回第一个大于等于key_value的定位器

set用法详解https://blog.csdn.net/yas12345678/article/details/52601454 

(上面那个详解有一点错误,注意看评论)

#include<cstdio>
#include<queue>
#include<set>
#include<cmath>
using namespace std;
struct node{
	int id,x;
	node(){};
	node(int a,int b){
		id=a;
		x=b;
	}
	bool operator<(const node other)const{
		return x<other.x;//x小的在前面
	}
};
int main(){
	int n,m;
	while(~scanf("%d",&n)&&n){
		set<node> s;
		set<node>::iterator it;
		s.insert(node(1,1000000000));
		for(int i=1;i<=n;i++){
			int id,x;
			scanf("%d%d",&id,&x);
			it=s.lower_bound(node(id,x));
			node t=*it;
			if(it!=s.begin()){
				it--;
				if(t.x-x>=x-(*it).x) printf("%d %d\n",id,(*it).id);
				else printf("%d %d\n",id,t.id);
			}
			else{
				printf("%d %d\n",id,t.id);
			}
			s.insert(node(id,x));
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/85536777