hdu 5724 -Chess sg 博弈

版权声明:本博客内容基本为原创,如有问题欢迎联系,未经允许请勿转载 https://blog.csdn.net/qq_41955236/article/details/82218301

Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3493    Accepted Submission(s): 1439


 

Problem Description

Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.

 

Input

Multiple test cases.

The first line contains an integer T(T≤100) , indicates the number of test cases.

For each test case, the first line contains a single integer n(n≤1000) , the number of lines of chessboard.

Then n lines, the first integer of ith line is m(m≤20) , indicates the number of chesses on the ith line of the chessboard. Then m integers pj(1≤pj≤20) followed, the position of each chess.

 

Output

For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.

 

Sample Input

 

2

1

2 19 20

2

1 19

1 18

 

Sample Output

 

NO

YES


题意:

      给你一个1000*20的棋盘。每一行(共2000行)上可能会有若干个棋子,现在小A和小B开始玩游戏,每个人可以把棋子向右移动一格(如果右边没有障碍物,共20列),如果有连续的格子,可以把这连续的一串都进行移动,直到一方不能移动为止。

做法:

     因为这道题去学了sg函数,结果发现自己好像还是不能独立写出来。看来还是要多多练习啊。。这道题就是状压,找到第一个空位之后向后找第一个棋子,并尝试把它移动过来,用vis进行记录。


代码如下:

    

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=(1<<20);
int sg[maxn];
bool vis[200];
void init(){
    for(int i=2;i<(maxn);i++){
        memset(vis,0,sizeof(vis));
        int bits[25],now=0,x=i;
        while(x){
            bits[++now]=x%2;
            x/=2;
        }
        int cnt=-1;
        for(int j=1;j<=now;j++){
            if(bits[j]){
                if(cnt!=-1)
                    vis[sg[i^(1<<(j-1))^(1<<(cnt-1))]]=1;
            }
            else cnt=j;
        }
        for(int j=0;;j++){
            if(!vis[j]) {
                sg[i]=j;
                break;
            }
        }
    }
}
int main(){
    init();
    int t,n;
    cin>>t;
    while(t--){
        scanf("%d",&n);
        int now=0,ans=0;
        for(int i=1;i<=n;i++){
            int num,tmp=0,x;
            scanf("%d",&num);
            while(num--){
                scanf("%d",&x);
                tmp^=(1<<(20-x));
            }
            ans^=sg[tmp];
        }
        if(ans) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41955236/article/details/82218301