胜利大逃亡(dfs)

     Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

    魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


Input
    输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

    特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
Output
    对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
Sample Input

    1
    3 3 4 20
    0 1 1 1
    0 0 1 1
    0 1 1 1
    1 1 1 1
    1 0 0 1
    0 1 1 1
    0 0 0 0
    0 1 1 0
    0 1 1 0

Sample Output

    11

分析:三维的深搜。要注意剪枝

#include<stdio.h>
#include<string.h>
int a,b,c,t,flag;
int map[51][51][51],book[51][51][51];

void dfs(int x,int y,int z,int step)
{
	int i,dx,dy,dz;
	int next[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
	if(step > t || step >= flag || (a+b+c-step-x-y-z > t))
		return ;
	if(x == a-1 && y == b-1 && z == c-1)
	{
		flag = step;
		return ;
	}
	for(i = 0; i < 6; i ++)
	{
		dx = x + next[i][0];
		dy = y + next[i][1];
		dz = z + next[i][2];
		if(dx < 0 || dx >= a || dy < 0 || dy >= b || dz < 0 || dz >= c)
			continue;
		if(map[dx][dy][dz] == 0 && (book[dx][dy][dz] == 0 || step < book[dx][dy][dz]))
		{
			book[dx][dy][dz] = step;
			map[dx][dy][dz] = 1;
			dfs(dx,dy,dz,step+1);
			map[dx][dy][dz] = 0;
		}
	}
}
 
int main()
{
	int i,j,k,T;
	scanf("%d",&T);
	while(T --)
	{
		scanf("%d%d%d%d",&a,&b,&c,&t);
		for(i = 0; i < a; i ++)
		{
			for(j = 0; j < b; j ++)
			{
				for(k = 0; k < c; k ++)
				{
					scanf("%d",&map[i][j][k]);
				}
			}	
		}
		memset(book,0,sizeof(book));
		flag = 1000;
		dfs(0,0,0,0);
		if(flag == 1000)
			printf("-1\n");
		else
			printf("%d\n",flag);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81184755
今日推荐