PTA刷题日记:L1-062 幸运彩票分数 15

题目:

彩票的号码有 6 位数字,若一张彩票的前 3 位上的数之和等于后 3 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。

输入格式:

输入在第一行中给出一个正整数 N(≤ 100)。随后 N 行,每行给出一张彩票的 6 位数字。

输出格式:

对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!;否则输出 Wish you good luck.

输入样例:

2
233008
123456

输出样例:

You are lucky!
Wish you good luck.

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

代码:

#include<iostream>
using namespace std;
int main()
{
	int n;
	cin>>n;
	string str;
	while(n)
	{
		n--;
		cin>>str;
		int sum1=0;
		int sum2=0;
		for(int i=0;i<3;i++)
		{
			sum1+=(str[i]-48);//0的assci码值是48 
		}
		for(int i=3;i<6;i++)
		{
			sum2+=(str[i]-48);
		}
		//cout<<sum1<<endl<<sum2;
		if(sum1==sum2) cout<<"You are lucky!"<<endl;
		else cout<<"Wish you good luck."<<endl;
	}
} 

猜你喜欢

转载自blog.csdn.net/qq_51701007/article/details/124869318