POJ 3041-Asteroids-二分图最大匹配

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

核心思想:

将两个数轴看作两个集合,平面内存在某一点(x,y)意味着二分图中x和y有一条边,求最大匹配即可。

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=520;
int n,G[N][N],p[N];
bool vis[N];
bool dfs(int x)
{
	for(int y=1;y<=n;y++)
	{
		if(!G[x][y]||vis[y])continue;
		vis[y]=1;
		if(!p[y]||dfs(p[y]))
		{
			p[y]=x;
			return 1;
		}
	}
	return 0;
}
int main()
{
	int k,x,y;
	cin>>n>>k;
	for(int i=0;i<k;i++)
	{
		scanf("%d%d",&x,&y);
		G[x][y]=1;
	}
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
			vis[j]=0;
		ans+=dfs(i);
	}
	cout<<ans<<endl;
	return 0;
}
发布了144 篇原创文章 · 获赞 135 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Nothing_but_Fight/article/details/102980868