Stones on the Table解决方法

Problem Description
There are n stones on the table in a row, each of them can be red, green or blue. Count the minimum number of stones to take from the table so that any two neighboring stones had different colors. Stones in a row are considered neighboring if there are no other stones between them.
Input
The first line contains integer n (1 ≤ n ≤ 50) — the number of stones on the table.
The next line contains string s, which represents the colors of the stones. We’ll consider the stones in the row numbered from 1 to n from left to right. Then the i-th character s equals “R”, if the i-th stone is red, “G”, if it’s green and “B”, if it’s blue.
Output
Print a single integer — the answer to the problem.
Sample Input

3
RRG

Sample Output

1
问题简述:
输入石头数,然后输入石头各颜色,从其中取出石头,使相邻石头不同颜色。输出取的最少次数。
问题分析:
另外设置一个整形变量,作为输出的“次数”,每发现相邻相同颜色,则增加一次。
c++语言程序如下:

#include <iostream>
using namespace std;
int main()
{
 char*a; 
 int n;
 cin >> n;
 a = new char[n];
 cin >> a;
 int t = 0;
 for (int i = 0; i < n - 1; i++)
  if (a[i] == a[i + 1]) t++;
 cout << t;
}

发布了27 篇原创文章 · 获赞 16 · 访问量 1910

猜你喜欢

转载自blog.csdn.net/weixin_43979090/article/details/84863174