【二分】LED

版权声明:版权声明:本文为博主原创文章,转载请注明出处。 https://blog.csdn.net/YT201758501112/article/details/89244180

题目描述

A Light-Emitting Diode (LED) is a semiconductor light source, which emits light when an electric current of voltage higher than a threshhold is applied to its leads. ACM R&D recently reported that they have succesfully developed a new LED, namely, ACMOLED. An ACMOLED has a special behavior that the intensity of light emitted from it changes in two steps as the voltage of the electric current increases, as depicted in the graph below.

As shown, an ACMOLED is not activated in the voltage range from 0 to V1, while it emits light with intensity L1 ≥ 0 when the voltage reaches the first threshold V1 and light with intensity L2 ≥ L1 when the voltage reaches the x threshold V2. More specifically, if F(v) is the function that maps voltage v to the intensity of light emitted from an ACMOLED, then for four real numbers L1, L2, V1, and V2 with 0 ≤ L1 ≤ L2 and 0 < V1 < V2, we have

The very issue now is that ACM R&D still does not know the exact values of two threshold voltage values V1 and V2 and the two intensity values L1 and L2 as well. Researchers in ACM R&D plan to estimate these four values for ACMOLEDs by repeated experiments.
Experiments are performed by applying current of a specific voltage and observing the intensity of light emitted from an ACMOLED. After n repeated experiments with different voltage values, obtained are the data of n tuples (v1, l1), (v2, l2), ..., (vn, ln), where li is the observed intensity for voltage vi. Due to the impreciseness of the observing device and other reasons, the experimental data are not accurate and may contain some error. Nonetheless, they want to find a best estimated intensity function F(v) that minimizes the following error function:

where |x| denotes the absolute value of a real number x.
For a given data of n tuples, write a program that finds an estimated intensity function F that minimizes the above error function and outputs the value of error(F).

输入

Your program is to read from standard input. The input starts with a line containing an integer n (1 ≤ n ≤ 300,000), where n is the number of tuples (vi, li) in the experimental data. In the following n lines, each line contains two integers, which range inclusively from 0 to 109, representing vi and li in each tuple (vi, li) of the experimental data. Note that you may assume that there are no two tuples (vi, li) and (vj, lj) in the input such that 1 ≤ i < j ≤ n and vi = vj.

输出

Your program is to write to standard output. Print exactly one line consisting of one real number, rounded to the first decimal place, which represents the minimum value of error(F).

样例输入

复制样例数据

5
0 0
2 1
3 5
6 7
7 11

样例输出

1.0

题目大意:

此题大体上就是在第一象限内给出n个点,输入第一行为n,下面n行为这n个点的坐标,现在要找出一个函数,形如图中给的阶梯型,要使的这些点到这个分段阶梯的距离的最大值最小化,并求出这个最小化的最大值。

解题思路:

此题是一道二分的题,我们可以通过二分点的误差范围,通过判断是否可以由这样三条直线来构成,来确定二分的条件,但需要注意的是,若第一个点的横坐标为0,即其在y轴上时,需要将左边界改为此时点的y值,因为此时这个点一定是落在第一条线段上的。

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
struct node
{
	double x,y;
	double up,down;
}arr[300100];
bool cmp(node a,node b) {
	return a.x<b.x;
}
int n;
bool judge(double d) {
	int t;
	rep(i,1,n) {
		if(arr[i].y-d>0) {     //将能放在第一条线段上的的点先去掉,即放在x轴上的
			t=i;
			break;
		}
	}
	int num=1;
	double up=arr[t].y+d,down=arr[t].y-d;
	for(int i=t+1;i<=n;i++) {
		if(arr[i].y+d<down) {       //此时不满足情况,即当前的点在线段下面了
			return false;
		}
		else if(arr[i].y-d>up) {      //当前的点在此时线段渠道的范围之上,需开一条新的线段
			num++;
			if(num>2) return false;
			up=arr[i].y+d;          //更新线段所在的区间
			down=arr[i].y-d;
		}
		else {
			up=min(up,arr[i].y+d);      //缩小线段所在的区间
			down=max(down,arr[i].y-d);
		}
	}
	return true;
}
int main() 
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
    #endif
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    scanf("%d",&n);
    double maxy=-1;
    rep(i,1,n) {
    	scanf("%lf %lf",&arr[i].x,&arr[i].y);
    	maxy=max(maxy,arr[i].y);
    }
    sort(arr+1,arr+1+n,cmp);
    double l=0,r=maxy;
    if(arr[1].x==0) l=arr[1].y;
    while(r-l>0.00001) {
    	double mid=(l+r)/2.0;
    	if(judge(mid)) {
    		r=mid;
    	}
    	else 
    		l=mid;
    }
    printf("%.1f\n",r);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/YT201758501112/article/details/89244180