Contestants Division POJ - 3140

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers st, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

题意:给你一棵树,树的每个节点都有一个权值,问你删掉一条边,使得分成的两棵树权值之和相差最小。

思路:dfs搜每个点的子树的权值之和,设为tmp,若从这个点的上一条边断开,则分成两个数的权值是tmp和sum-tmp,

那么他们的差为abs(sum-2*tmp);我们用ans维护一个最小值即可。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=100009;
const int maxm=1000009;
struct node{
	int id;
	int next;
}side[maxm*2];
int head[maxn],cnt,n,m;
ll val[maxn],sum,ans;
void init()
{
	memset(head,-1,sizeof(head));
	cnt=sum=0;
}
ll Abs(ll x)
{
	if(x<=0)
		return -x;
	else
		return x;
}
void add(int x,int y)
{
	side[cnt].id=y;
	side[cnt].next=head[x];
	head[x]=cnt++;
}
ll dfs(int x,int fa)
{
	ll tmp=val[x];
	for(int i=head[x];i!=-1;i=side[i].next)
	{
		int y=side[i].id;
		if(y==fa) continue;
		tmp+=dfs(y,x);
	}
	ans=min(ans,Abs(sum-2*tmp));
	return tmp;
}
int main()
{
	int x,y,cas=1;
	while(scanf("%d%d",&n,&m)&&(m+n))
	{
		init();
		for(int i=1;i<=n;i++)
		{
			scanf("%lld",&val[i]);
			sum+=val[i];	
		}
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			add(x,y);
			add(y,x);
		}
		ans=sum;
		dfs(1,-1);
		printf("Case %d: %lld\n",cas++,ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/why932346109/article/details/88540933