7-25 字符串排序 (20 分)

本题要求编写程序,读入5个字符串,按由小到大的顺序输出。

输入格式:

输入为由空格分隔的5个非空字符串,每个字符串不包括空格、制表符、换行符等空白字符,长度小于80。

输出格式:

按照以下格式输出排序后的结果:

After sorted:
每行一个字符串

输入样例:

red yellow blue green white

输出样例:

After sorted:
blue
green
red
white
yellow
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std ;
struct string1{
	char str[80] ;
};
bool cmp(string1 s1,string1 s2)
{ 
	return strcmp(s1.str,s2.str)<0;
}
int main()
{
	struct string1 S[5] ;
	for(int i=0;i<5;i++)
		scanf("%s",S[i].str) ;
	sort(S,S+5,cmp) ;
	printf("After sorted:\n") ;
	for(int i=0;i<5;i++)
		printf("%s\n",S[i].str) ;
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41591279/article/details/87929081