HDU - 2101 A + B Problem Too【水题】

A + B Problem Too

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21290 Accepted Submission(s): 15584

Problem Description
This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

Sample Input
1 1
8600 8600

Sample Output
no
yes

Source
HDU 2007-6 Programming Contest

Recommend
xhd

问题链接:https://vjudge.net/problem/HDU-2101。

问题简述:输入两个整数,若这两个整数之和能被86整除,则输出“yes”,否则输出“no”。

问题分析:利用while循环输入,判断该两个整数之和能否被86整除即
if ((a+b) % 86 == 0),用 if-else 语句分别输出两种情况的不同输出结果。

程序说明:利用while循环,判断,利用 if-else 语句。

AC通过的C语言程序如下:

#include <iostream>
using namespace std;

int main()
{
	int a;
	int b;
	while (cin >> a >> b)
	{
		if ((a+b) % 86 == 0)
		{
			cout << "yes" << endl;
		}
		else
		{
			cout << "no" << endl;
		}
	}
}


猜你喜欢

转载自blog.csdn.net/qq_43966202/article/details/84886343