【二分答案】 POJ - 2456 B - Aggressive cows

B - Aggressive cows POJ - 2456 

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

二分最小值的最大值 

 while(l<=r)
 {
       int mid=(l+r)/2;
       if(ok(mid))
       {
           l=mid+1;
           ans=mid;
       }
       else r=mid-1;
 }
 printf("%d\n",ans);
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[100005];
int n,m;

bool ok(int x)
{
    int l=1,num=1;
    for(int i=2;i<=n;i++)
    {
        if(a[i]-a[l]>=x)
        {
            num++;
            l=i;
        }
        if(num>=m) return 1;
    }
    return 0;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a+1,a+n+1);
        //for(int i=1;i<=n;i++) cout<<a[i]<<" ";
        int l=1,r=a[n]-a[1],ans=0;
        while(l<=r)
        {
            int mid=(l+r)/2;
            if(ok(mid))
            {
                l=mid+1;
                ans=mid;
            }
            else r=mid-1;
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/83003025