北京大学OpenJudge 3438:Balanced Lineup(线段树入门)

版权声明:版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37618760/article/details/81944302

3438:Balanced Lineup

总时间限制: 

5000ms

单个测试点时间限制: 

2000ms

内存限制: 

65536kB

描述

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

输入

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

输出

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

样例输入

6 3
1
7
3
4
2
5
1 5
4 6
2 2

样例输出

6
3
0

Source  File

#include <iostream>
using namespace std;
#define INF 0xffffff0
int minV=INF;
int maxV=-INF;
struct Node{
    int L,R;
    int minV,maxV;
    int Mid(){
        return (L+R)/2;
    }
};
Node tree[801000];
void BuildTree(int root,int L,int R){//建树
    //用root控制每个节点的下标
       tree[root].L=L;
       tree[root].R=R;
       tree[root].minV=INF;
       tree[root].maxV=-INF;
       if(L!=R){
        BuildTree(2*root+1,L,(L+R)/2);
        BuildTree(2*root+2,(L+R)/2+1,R);
       }
}
void Insert(int root,int i,int v){//插入数的过程
    if(tree[root].L==tree[root].R){
        tree[root].minV=tree[root].maxV=v;
        return ;
    }
    tree[root].minV=min(tree[root].minV,v);
    tree[root].maxV=max(tree[root].maxV,v);
    if(i<=tree[root].Mid())
        Insert(2*root+1,i,v);
    else
        Insert(2*root+2,i,v);
}
void Query(int root,int s,int e){
    if(tree[root].minV>=minV&&tree[root].maxV<=maxV)
        return ;//相当于剪枝
    if(tree[root].L==s&&tree[root].R==e){
        minV=min(minV,tree[root].minV);
        maxV=max(maxV,tree[root].maxV);
        return;
    }
    if(e<=tree[root].Mid())
        Query(2*root+1,s,e);
    else if(s>tree[root].Mid())
        Query(2*root+2,s,e);
    else{
        Query(2*root+1,s,tree[root].Mid());
        Query(2*root+2,tree[root].Mid()+1,e);
    }
}
int main()
{
    int n,q,h;
    int i;
    scanf("%d %d",&n,&q);
    BuildTree(0,1,n);
    for(i=1;i<=n;i++){
        scanf("%d",&h);
        Insert(0,i,h);
    }
    for(i=0;i<q;i++){
        int s,e;
        scanf("%d %d",&s,&e);
        minV=INF;
        maxV=-INF;
        Query(0,s,e);
        printf("%d\n",maxV-minV);
    }
    return 0;
}

思路:我们来思考样例执行的过程,用一张图就可以直白的表达出来

           

 其实就是我们建立了一个树(和二叉树有点相似),我们按照序号从1到n建立这个数,然后对应下标插入给定的各个数,在不断插入的过程中更新最大值还有最小值,最后在差值当中选择一个最大的输出结束程序。

猜你喜欢

转载自blog.csdn.net/qq_37618760/article/details/81944302