算法笔记(入门篇1-入门模拟)--字符串处理--问题 G: 比较字符串

问题 G: 比较字符串

时间限制: 1 Sec  内存限制: 32 MB

题目描述

输入两个字符串,比较两字符串的长度大小关系。

输入

输入第一行表示测试用例的个数m,接下来m行每行两个字符串A和B,字符串长度不超过50。

输出

输出m行。若两字符串长度相等则输出A is equal long to B;若A比B长,则输出A is longer than B;否则输出A is shorter than B。

样例输入

2
abc xy
bbb ccc

样例输出

abc is longer than xy
bbb is equal long to ccc
#include<stdio.h>
#include<string.h>
int main()
{
    char a[205],b[205];
    int len1,len2,m;
    while(scanf("%d",&m)!=EOF)
    {
        while(m--)
        {
            scanf("%s %s",a,b);
            len1=strlen(a);
            len2=strlen(b);
            if(len1==len2)
                printf("%s is equal long to %s\n",a,b);
            if(len1>len2)
                printf("%s is longer than %s\n",a,b);
            if(len1<len2)
                printf("%s is shorter than %s\n",a,b);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/syd1091245120/article/details/81570673
今日推荐