简单计算器 STL 栈

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。 

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。 

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。 

Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output

3.00
13.36

#include <stack>
#include <cstdio>
#include <cstring>
#include <algorithm> 
using namespace std;
int main() {
    double n, temp;
    char b, c[2];
    while (scanf("%lf%c", &n, &b)) {
        if (n == 0 && b == '\n') break;
        double ans = 0;
        stack<double> stk;
        stk.push(n);
        while (scanf("%s %lf", c, &n) != EOF) {
            if (c[0] == '+')   stk.push(n);
            else if (c[0] == '-')  stk.push(-n);
            else if (c[0] == '*') {
                temp = n*stk.top();
                stk.pop();
                stk.push(temp);
            }
            else {
                temp = stk.top()/n;
                stk.pop();
                stk.push(temp);
            }
            if (b = getchar() , b == '\n') break;
        }
        while (!stk.empty()) {
            ans += stk.top();
            stk.pop();
        }
        printf("%.2lf\n", ans);
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/qq_40835329/article/details/81610013