HDU 6208 The Dominator of Strings

Problem Description

Here you have a set of strings. A dominator is a string of the set dominating all strings else. The string S is dominated by T if S is a substring of T.

Input

The input contains several test cases and the first line provides the total number of cases.
For each test case, the first line contains an integer N indicating the size of the set.
Each of the following N lines describes a string of the set in lowercase.
The total length of strings in each case has the limit of 100000.
The limit is 30MB for the input file.

Output

For each test case, output a dominator if exist, or No if not.

Sample Input

3

10

you

better

worse

richer

poorer

sickness

health

death

faithfulness

youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness

5

abc

cde

abcde

abcde

bcde

3

aaaaa

aaaab

aaaac

Sample Output

youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness

abcde

No

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int MAXN = 100010;
string s[MAXN];
int main() {
	int t, n;
	cin.sync_with_stdio(false);//防超时
	cin>>t;;
	while(t--) {
		cin>>n;
		int maxl = 0;
		string a;
		for(int i = 0; i < n; i++) {
			cin>>s[i];
			if(s[i].size() > maxl) {
				maxl = s[i].size();
				a = s[i];
			}
		}
		int flag = 1;
  		for(int i = 0; i < n; i++) {
            if(a == s[i]) continue;
            int k = a.find(s[i]);
            if(k > a.size()) {
                flag = 0;
                break;
            }
        }
        flag==1?cout<<a<<endl:cout<<"No"<<endl;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Adusts/article/details/81451376