HDUOJ 1096

A+B for Input-Output Practice (VIII)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 184702 Accepted Submission(s): 55248

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6

Author
lcy

#include<stdio.h>
int main()
{
    int n,a[100],sum,m,i;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d",&m);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
            sum=sum+a[i];
        }
        if(n!=0)
            printf("%d\n\n",sum);
        if(n==0)
            printf("%d\n",sum);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41897234/article/details/80487901