问题 A: Course List for Student (25)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

思路

题目中有个很重要的一点就是,学生的姓名格式是三个大写字母,外加一个阿拉伯数字。
在算法笔记讲解散列的地方,讲到如何将一个字符串转换成对应的数字,以时间换空间。通过进制转换的方式。之后,将课程id存入到每个学生的vector中即可。

#include<bits/stdc++.h>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string.h>
using namespace std;
int stu_num,cou_num;
const int maxn = 26*26*26+10;
vector<int> stu_cour[maxn];
vector<int>::iterator star;
vector<int>::iterator en;
//字符串hash是指将一个字符串映射为一个整数,使得该整数可以唯一的表示字符串
int hashFunc(char *s) {
    
    
	int id =  0;
	for(int i =0; i<3; i++) {
    
    
		id  = id * 26 + s[i] - 'A';
	}
	id = id + s[3] -'0';
	return id;
}
int main() {
    
    
	scanf("%d %d",&stu_num,&cou_num);
	int cid,sn;
	char stunm[5];
	char seanm[5];
	int hashstunm;
	for(int i = 0; i<cou_num; i++) {
    
    
		scanf("%d %d",&cid,&sn);
		for(int j = 0; j<sn; j++) {
    
    
			scanf("%s",stunm);
			hashstunm = hashFunc(stunm);
			stu_cour[hashstunm].push_back(cid);
		}
	}
	for(int i = 0; i<stu_num; i++) {
    
    
		scanf("%s",seanm);
		hashstunm = hashFunc(seanm);
		int lang  = stu_cour[hashstunm].size();
		printf("%s",seanm);
		printf(" %d",lang);
		star = stu_cour[hashstunm].begin();
		en = stu_cour[hashstunm].end();
		sort(star,en);
		for(; star != en; star ++)
			printf(" %d",*star);
		printf("\n");
	}
}

猜你喜欢

转载自blog.csdn.net/q54188p/article/details/114442722
今日推荐