PAT 1132 Cut Integer python解法

1132 Cut Integer (20 分)
Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31). It is guaranteed that the number of digits of Z is an even number.

Output Specification:
For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No

题意:将一个长整数Z切成两半A和B,如果满足Z/(A*B)没有余数,则输出Yes,否则输出No。

解题思路:
1.根据题意,首先把字符串z切开成两半a和b,因为分母b不能为0,所以需要先判断b非零。
2.然后利用题目所给公式进行计算,如果满足公式则输出Yes,否则输出No。

n = int(input())
for i in range(n):
    z = input()
    a = int(z[:len(z)//2])
    b = int(z[len(z)//2:])
    if b:
        if int(z)%(a*b):
            print('No')
        else:
            print('Yes')
    else:
        print('No')

猜你喜欢

转载自blog.csdn.net/qq_36936510/article/details/86570352