习题11-2 查找星期 (15point(s)).c

本题要求实现函数,可以根据下表查找到星期,返回对应的序号。

序号	星期
0   Sunday
1	Monday
2	Tuesday
3	Wednesday
4	Thursday
5   Friday
6	Saturday

函数接口定义:

int getindex( char *s );

函数getindex应返回字符串s序号。如果传入的参数s不是一个代表星期的字符串,则返回-1。

裁判测试程序样例:

#include <stdio.h>
#include <string.h>

#define MAXS 80

int getindex( char *s );

int main()
{
    int n;
    char s[MAXS];

    scanf("%s", s);
    n = getindex(s);
    if ( n==-1 ) printf("wrong input!\n");
    else printf("%d\n", n);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

Tuesday

输出样例1:

2

输入样例2:

today

输出样例2:

wrong input!
//   Date:2020/4/8
//   Author:xiezhg5
#include <stdio.h>
#include <string.h>

#define MAXS 80

int getindex( char *s );

int main()
{
    int n;
    char s[MAXS];

    scanf("%s", s);
    n = getindex(s);
    if ( n==-1 ) printf("wrong input!\n");
    else printf("%d\n", n);

    return 0;
}

/* 你的代码将被嵌在这里 */
int getindex( char *s )
{
	int week;
	//用数组就很简单
	char *day[7]={"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"};
    for(week=0;week<=6;week++)
    	//用week作数组元素下标
    	//巧妙调用strcmp函数(比较大小)
    	if(strcmp(s,day[week])==0)
    		break;
    	if(week==7)
    		week=-1;
    	return week;
}
发布了208 篇原创文章 · 获赞 182 · 访问量 8640

猜你喜欢

转载自blog.csdn.net/qq_45645641/article/details/105380285