Children’s Queue

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

Sample Input

1
2
3

Sample Output

1
2
4

分析:

1)题目大意
排队。F代表女孩,M代表男孩。男女生排队,这个队列中可以没有女孩,如果有女孩,不能自己站着,即得有陪同。
2)解题分析:
递推+大数
计算F(n)
1.当最后一个是男孩时,前n-1个随便排,只要符合要求,即F(n-1);
2.当最后一个时女孩时,第n-1个肯定是女孩,分两种情况:
a.前n-2个同前n-1那样,即F(n-2);
b.若前面n-2个人不是合法的队列,加上后两个女生也有可能是合法的。当第n-2是女孩而n-3是男孩的情况,可能合法,情况总数为F(n-4);
(参考http://blog.csdn.net/xujinsmile/article/details/7364307

也可找规律
1->1
2->2
3->4
4->7
5->12
即F(n)=F(n-1)+F(n-2)+F(n-4).

代码

import java.util.*;
import java.math.*;

public class Main {

    public static void main(String[] args) {
        BigInteger f[]=new BigInteger[1001];
        //同斐波那契数列,先大数打表
        f[0]=new BigInteger("1");
        f[1]=new BigInteger("1");
        f[2]=new BigInteger("2");
        f[3]=new BigInteger("4");
        for(int i=4;i<=1000;i++)
        {
            f[i]=f[i-1].add(f[i-2]).add(f[i-4]);
        }
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){//输入,同C,EOF结束
            int m=sc.nextInt();
            System.out.println(f[m]);
        }   
    }
}

猜你喜欢

转载自blog.csdn.net/lshsgbb2333/article/details/79966135