PAT-2019年冬季考试 - Class -7-3 Summit (25 points) and exam similar to the 1142 general difficulty of questions

topic

7-3 Summit (25 points)

A summit (峰会) is a meeting of heads of state or government. Arranging the rest areas for the summit is not a simple job. The ideal arrangement of one area is to invite those heads so that everyone is a direct friend of everyone.

Now given a set of tentative arrangements, your job is to tell the organizers whether or not each area is all set.
Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 200), the number of heads in the summit, and M, the number of friendship relations. Then M lines follow, each gives a pair of indices of the heads who are friends to each other. The heads are indexed from 1 to N.

Then there is another positive integer K (≤ 100), and K lines of tentative arrangement of rest areas follow, each first gives a positive number L (≤ N), then followed by a sequence of L distinct indices of the heads. All the numbers in a line are separated by a space.
Output Specification:

For each of the K areas, print in a line your advice in the following format:

  • if in this area everyone is a direct friend of everyone, and no
    friend is missing (that is, no one else is a direct friend of
    everyone in this area), print Area X is OK.
  • if in this area everyone is a direct friend of everyone, yet there
    are some other heads who may also be invited without breaking the
    ideal arrangement, print Area X may invite more people, such as H.where H is the smallest index of the head who may be invited.
  • if in this area the arrangement is not an ideal one, then print Area
    X needs help. so the host can provide some special service to help
    the heads get to know each other.

Here X is the index of an area, starting from 1 to K.
Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
2 4 6
3 3 2 1
Sample Output:

Area 1 is OK.
Area 2 is OK.
Area 3 is OK.
Area 4 is OK.
Area 5 may invite more people, such as 3.
Area 6 needs help.

This question is no pit, meaning of the questions as follows:

No more than 200 people, numbered from 1 to N
to give friendship
and then give the party asked the personnel numbers are not all friends?
Not, then I do seek help; it is, then divided into two types
one is not a friend is not a party to the
other is also invited another party, please small number of

Bad Code

#include<iostream>
#include<vector>
using namespace std;
int n,m,k;
int main(){
    scanf("%d %d\n",&n,&m);
    int G[n+5][n+5];
    vector<vector<int>> va(n+5);
    va.clear();
    int u,v,l;
    for(int i=0;i<m;i++){
        scanf("%d %d\n",&u,&v);
        G[u][v]=G[v][u]=1;
        va[u].push_back(v);
        va[v].push_back(u);
    }
    scanf("%d\n",&k);
    for(int i=0;i<k;i++){
        scanf("%d",&l);
        int a[l];
        set<int> s;
        for(int j=0;j<l;j++){
            scanf("%d",&a[j]);
            s.insert(a[j]);
        }
        if(l==1&&va[a[0]].size()==0){
            printf("Area %d is OK.\n",i+1);
            continue;
        }
        bool f1=true,f2=true;
        for(int j=0;j<l-1;j++){
            for(int k=j+1;k<l;k++){
                int x=a[j],y=a[k];
                if(G[x][y]!=1){
                    f1=false;
                }
            }
        }
        if(!f1){
            printf("Area %d needs help.\n",i+1);
        }else{
            int minn=n+1;
            for(int k=1;k<=n;k++){
                bool f3=true;
                for(auto it:s){
                    if(G[k][it]!=1){
                        f3=false;
                    }
                }
                if(f3 && s.find(k)==s.end() && k<minn){
                    minn=k;
                    f2=false;
                    continue;
                }
            }

            if(f2){
                printf("Area %d is OK.\n",i+1);
            }else{
                printf("Area %d may invite more people, such as %d.\n",i+1,minn);
            }
        }

    }
    return 0;
}
Published 21 original articles · won praise 1 · views 1183

Guess you like

Origin blog.csdn.net/allisonshing/article/details/104094815