HDU 3177 Crixalis's Equipment

贪心

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3177

Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 

Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 

Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
 

Sample Input
 
  
2 20 3 10 20 3 10 1 7 10 2 1 10 2 11
 

Sample Output
 
  
Yes No

#include<iostream>
#include<algorithm>
using namespace std;
#define N 1001
typedef struct{
    int a,b;
}spaces;
spaces space[N];

bool cmp(spaces p,spaces q){
    if((p.a+q.b)!=(p.b+q.a))
        return (p.a+q.b)<(p.b+q.a);
    return p.b<q.b;
}

int main()
{
//    freopen("E:\\in.txt","r",stdin);
    int T;
    cin>>T;
    while(T--){
        bool flag=true;
        int i,hole,n;
        cin>>hole>>n;
        for(i=0;i<n;i++){
            cin>>space[i].a>>space[i].b;
        }
        sort(space,space+n,cmp);
        for(i=0;i<n;i++){
            if(hole>=space[i].b&&hole>=space[i].a){
                hole-=space[i].a;
            }
            else {
                flag=false;
                break;
            }
        }
        if(flag)cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}


发布了54 篇原创文章 · 获赞 62 · 访问量 10万+

猜你喜欢

转载自blog.csdn.net/u013053268/article/details/48346725
今日推荐