Race LightOJ - 1326----DP

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded and wandered around, even in their holidays. They passed several months in this way. But everything has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing). Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this is their romance!

In a race there are n horses. You have to output the number of ways the race can finish. Note that, more than one horse may get the same position. For example, 2 horses can finish in 3 ways.

1. Both first
2. horse1 first and horse2 second
3. horse2 first and horse1 second

Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1000).

Output
For each case, print the case number and the number of ways the race can finish. The result can be very large, print the result modulo 10056.

Sample Input
3
1
2
3
Sample Output
Case 1: 1
Case 2: 3
Case 3: 13

**解析:设f[i][j]表示:i匹马确定j个名次。
f[i][j]=f[i-1][j]*j+f[i-1][j-1]*j.i-1匹马确定j个名次,那么第i匹马成为1-j名。要么i-1匹马确定j-1个名次,那么第i匹马有了新的名次,名次又有1-j名



#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int N=1005;
const int MOD=10056;
int f[N][N];
int t,n;
void init()
{
	f[1][1]=1;
	for(int i=2;i<=1005;i++)
	{
		for(int j=1;j<=i;j++)
		{
			f[i][j]=(f[i-1][j]*j+f[i-1][j-1]*j)%MOD;
		}
	}
}
int main()
{
	scanf("%d",&t);
	init();
	int k=1;
	while(t--)
	{
		scanf("%d",&n);
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			sum=(sum+f[n][i])%MOD;
		}
		printf("Case %d: %d\n",k++,sum);
	
	}
}
发布了284 篇原创文章 · 获赞 6 · 访问量 3796

猜你喜欢

转载自blog.csdn.net/qq_43690454/article/details/103975286