Telephone Wire POJ - 3612---dp+转换

Farmer John’s cows are getting restless about their poor telephone service; they want FJ to replace the old telephone wire with new, more efficient wire. The new wiring will utilize N (2 ≤ N ≤ 100,000) already-installed telephone poles, each with some heighti meters (1 ≤ heighti ≤ 100). The new wire will connect the tops of each pair of adjacent poles and will incur a penalty cost C × the two poles’ height difference for each section of wire where the poles are of different heights (1 ≤ C ≤ 100). The poles, of course, are in a certain sequence and can not be moved.

Farmer John figures that if he makes some poles taller he can reduce his penalties, though with some other additional cost. He can add an integer X number of meters to a pole at a cost of X2.

Help Farmer John determine the cheapest combination of growing pole heights and connecting wire so that the cows can get their new and improved service.

Input

  • Line 1: Two space-separated integers: N and C
  • Lines 2…N+1: Line i+1 contains a single integer: heighti

Output

  • Line 1: The minimum total amount of money that it will cost Farmer John to attach the new telephone wire.

Sample Input
5 2
2
3
5
1
4
Sample Output
15

解析:设f[i][j]:表示第i个柱子的高度为j的最小花费。
很容易想出递推方程
f[i][j]=min(f[i-1][k]+(j-a[i])^2+abs(j-k)*c);
但这是一个O(nh^2);
所以我们需要把绝对值拆开来讨论
f[i][j]=min(f[i-1][k]+c*j-c*k+(j-a[i])^2); (j>=k)
f[i][j]=min(f[i-1][k]+k*c-c*j+(j-a[i])^2); (j<=k)
我们需要正反序遍历一遍正序前要更新一下mi=min(f[i-1][k]-c*k).
正序从a[i]--100;mi=min(f[i-1][j]-c*j);
反序从100--a[i];mi=min(f[i-1][j]+c*j);

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e5+10;
int f[N][101];
int a[N];
int n,c;
int main()
{
	scanf("%d %d",&n,&c);
	for(int i=1;i<=n;i++) scanf("%d",&a[i]);
	memset(f,67,sizeof f);
	for(int i=a[1];i<=100;i++ ) f[1][i]=(i-a[1])*(i-a[1]);//预处理 
	for(int i=2;i<=n;i++)
	{
		int mi=1e9;
		for(int k=1;k<a[i];k++) mi=min(mi,f[i-1][k]-c*k); //第i-1根柱子的高度为k,因为低于i根柱子高度所以-c*k; 
		for(int j=a[i];j<=100;j++)//j>=k; 
		{
			mi=min(mi,f[i-1][j]-c*j); // 第i-1根柱子的高度为j,减去c*j 
			f[i][j]=min(f[i][j],mi+c*j+(j-a[i])*(j-a[i]));//第i根柱子的高度为j,因为j>=k; +c*j
		}
		mi=1e9;
		for(int j=100;j>=a[i];j--)// j<=k
		{
			mi=min(mi,f[i-1][j]+c*j);//第i-1根柱子的高度为j,+c*j 
			f[i][j]=min(f[i][j],mi-c*j+(j-a[i])*(j-a[i]));//第i根柱子的高度为j,因为j<=k;-c*j 
		}
	}
	int ans=0x3f3f3f3f;
	for(int i=a[n];i<=100;i++) ans=min(ans,f[n][i]);
	cout<<ans<<endl;
}
发布了284 篇原创文章 · 获赞 6 · 访问量 3795

猜你喜欢

转载自blog.csdn.net/qq_43690454/article/details/103981708