The Suspects POJ - 1611---并查集/维护出现的次数

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

题意:
现在有n个学生(0号到n-1),其中0号学生是有可能非典的,只要和被怀疑有非典的学生在一个社团的学生都是有可能有非典的且需要被隔离,但是学校有很多社团,所以现在要你求一共有多少学生需要被隔离?

输入:多组实例.每个实例第一行n和m (0 <n <= 30000 and 0 <= m <= 500),表示学生从0到n-1,接下来有m行,每行描述一个社团的所有成员.每行首先是一个k,表示该社团有k个成员,接下来是这k个成员的编号.当一组实例n=0且m=0,表示输入结束.


解析:n个学生都有一个编号,一个社团的先合并到一起,有关系的自然会并在一起,只要最后find(0)即可。需维护集合个数详细看代码

#include<iostream>
#include<cstdio>
using namespace std;
const int N=1e5+100;
int fa[N];
int size[N];
int n,m,k,a,b;
int find(int x)
{
	if(x!=fa[x]) return fa[x]=find(fa[x]);
	return fa[x];
}
void build(int a,int b)
{
	a=find(a);
	 b=find(b);
	if(a!=b)
	{
		size[b]+=size[a];
		fa[a]=b;
	}
}
int main()
{
	while(~scanf("%d %d",&n,&m)&&n!=0||m!=0)
	{
	for(int i=0;i<n;i++)
	{
		fa[i]=i;
		size[i]=1;
	}
	while(m--)
	{
		cin>>k>>a;
		for(int i=1;i<=k-1;i++) 
		{
			cin>>b;
			build(a,b); 
		}
	}
	cout<<size[find(0)]<<endl;
	}
}

发布了284 篇原创文章 · 获赞 6 · 访问量 3781

猜你喜欢

转载自blog.csdn.net/qq_43690454/article/details/104033833