tensorflow-GPU版本安装教程(踩坑大全,看我踩坑就够了)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/AI_JOKER/article/details/102757985

今天给实验室服务器配置tensorflow的GPU版本,先吐槽一下实验室的破网。。。

下载之前看了很多博客的介绍,tensorflow-gpu版本需要cuda和cudnn并且版本必须要对应,就在我发愁要找对应版本的时候,突然看到可以一行命令全部下载,心中顿喜

1、使用cmd输入

conda install tensorflow-gpu

这种方法比较简便,所有需要用到包都自动下载了(这种方法十分推荐,真省心)

显示如下

问y/n回答是y

2、就在一切都很顺利的时候,有三个包下载时候因为实验室网速卡的原因没有下载成功,报错如下

3、解决方法

选择按照url所提示的网址把文件下载下来放到target提示的路径中,随后使用命令(注意此时输入命令应该在target提示的路径下)

conda install --offline ./tensorflow-base-2.0.0-gpu_py37h390e234_0.tar.bz2

这样就安装成功了

4、

好不容易全部都下载成功了,我迫不及待想试一下tensorflow,于是在命令行中输入pyhon进入python的环境中,输入

import tensorflow,天啊我以为全部安装就结束了,噩梦继续

报错;

numpy.core.multiarray failed to import

既然Numpy有问题,所以更新numpy

pip install --upgrade numpy

 

猜你喜欢

转载自blog.csdn.net/AI_JOKER/article/details/102757985