Java-链表的有序集合

链表的有序集合

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

  集合有一个重要的特性:互异性,即集合中任意两个元素都是不同的,互异性使得集合中的元素没有重复。给你 n 个包含重复数字的无序正整数序列,建立一个有序链表,链表中的结点按照数值非降序排列且不包含重复元素,输出该有序链表。

Input

输入包含多组测试数据,对于每组测试数据:
输入的第一行为一个正整数 n(1 ≤ n ≤ 100),
第二行为 n 个正整数 b 1,b 2,...,b n(0 ≤ b i ≤ 2 30)。

Output

对于每组测试数据,按照非降序输出链表的节点值。

Sample Input

1
2
2
1 1
6
6 3 5 2 2 3

Sample Output

2
1
2 3 5 6

Hint

 

import java.util.*;
import java.lang.*;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int t = sc.nextInt();
			long a[] =  new long[t];
			for(int i = 0; i < t; i++){
				a[i] = sc.nextLong();
			}
			Arrays.sort(a);
			System.out.print(a[0]);
			for(int i = 1; i < t; i++) {
				int flag = 0;
				for(int j = 0; j < i; j++) {
					if(a[i] == a[j]) {
						flag = 1;
						break;
					}
				}
				if(flag == 0) {
					System.out.print(" " + a[i]);
				}
			}
			System.out.println();
		}
		
		sc.close();
	}

}


或者(no

import java.util.*;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()) {
            int n = sc.nextInt();

            Set<Integer> set = new TreeSet<Integer>();//要升序排,所以TreeSet,存整数

            while(n-- != 0) {
                set.add(sc.nextInt());//set集合自然没有重复元素
            }

            Iterator<Integer> it = set.iterator();
            System.out.print(it.next());//it.next()返回迭代的下一个元素!!防止输出错误
            while(it.hasNext()) {
                System.out.print(" " + it.next());

            }
            System.out.println();
        }
        sc.close();
    }
}

猜你喜欢

转载自blog.csdn.net/slyslyme/article/details/80077470