路由交换与技术eigrp实验三

实验目的:

          1、学会实验出错时排查。

          2、掌握eigrp协议的配置。

          3、掌握路由器的基本命令配置。

          4、熟练掌握GNS3软件的配置方法。

          5、进一步理解网络配置的基本原理。

实验拓扑:

实验步骤:

1、配置路由器IP地址,并使用ping命令查看直连口的连通性

R1配置命令:

R1#configure ter  

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#inter

R1(config)#interface  f0/0

R1(config-if)#ip address 192.168.1.2 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#interface lo0

R1(config-if)#ip address 10.52.0.1 255.255.255.0    

R1(config-if)#ip address 10.52.1.1 255.255.255.0  secondary

R1(config-if)#ip address 10.52.2.1 255.255.255.0  secondary

R1(config-if)#ip address 10.52.3.1 255.255.255.0  secondary

R1(config-if)#

 

R2配置命令:

R2#confi t

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#interface f0/1

R2(config-if)#ip address 192.168.1.1 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#interface lo0

R2(config-if)#ip address

R2(config-if)#ip address 192.168.4.1 255.255.255.0

R2(config-if)#inter f0/0

R2(config-if)#ip addr

R2(config-if)#ip address 192.168.2.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)

R3配置命令:

R3#configure t

Enter configuration commands, one per line.  End with CNTL/Z.

R3(config)#interface f0/1

R3(config-if)#ip address 192.168.2.1 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#

*Apr  1 22:30:19.651: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

*Apr  1 22:30:20.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R3(config-if)#interface lo0

R3(config-if)#ip a

*Apr  1 22:30:41.831: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

R3(config-if)#ip address 10.62.4.1 255.255.255.0

R3(config-if)#ip address 10.62.5.1 255.255.255.0 second  

R3(config-if)#ip address 10.62.5.1 255.255.255.0 secondary

R3(config-if)#ip address 10.62.6.1 255.255.255.0 secondary

R3(config-if)#ip address 10.62.7.1 255.255.255.0 secondary

R3(config-if)#interface lo1

R3(config-if)#ip

R3(config-if)#ip address 192.168.5.1 255.255.255.0

R3(config-if)#interface lo2

R3(config-if)#ip address 211.67.188.1 255.255.255.252

2、在三台路由配置EIGRP 自治系统编号为52

R1配置命令:

R1(config)#router eigrp 52

R1(config-router)#network 192.168.1.0 0.0.0.255

R1(config-router)#network 192.168.3.0 0.0.0.255

R1(config-router)#network 10.0.0.0

R2配置命令:

R2(config)#router eigrp 52

R2(config-router)#network 192.168.4.0

R2(config-router)#network 192.168.1.0

R2(config-router)#network 192.168.2.0

R3配置命令:

R3(config)#router eigrp 52

R3(config-router)#network 10.0.0.0

R3(config-router)#network 192.168.2.0

R3(config-router)#network 192.168.5.0

R3(config-router)#end

 

问题1查看各路由器的路由表,在R1上ping 10.62.4.1,能否ping通?

     答:ping不通,路由表中没有此条路由

 

3、在任意一台路由器上观察EIGRP 的邻居关系

R1#show ip eigrp neighbors

4在任意一台路由器上查看路由表

R1#show ip route

 

 

 

 

 

 

5在各路由器上查看EIGRP拓扑表

R1#show ip eigrp topology

R2#show ip eigrp topology

R3#show ip eigrp topology

 

问题2在拓扑表中包含几条记录?举例说明其中一条记录的AD和FD值,并写出其FD计算过程。

      答:在R1和R3上包含9条记录,R2上只包含5条记录,

             举例说明R1上192.168.2.0记录的FD说明:

FD = 256 * (107/100000 + 100*2/10 ) = 30720

metric = 256 *10^7/最小带宽 + 延迟总和/10

带宽单位为kbps,延迟单位为usec

fastethernet的带宽为100000kbps,延迟为100usec

 

6在各路由器上查看EIGRP接口、

 R1#show ip eigrp interfaces

R2#show ip eigrp interfaces

 

 

R3#show ip eigrp interfaces

7查看协议信息 参考命令:

R1#show ip protocols

8关闭各路由器自动汇总,清空路由表

R1配置命令:

R1(config)#router eigrp 52                 

R1(config-router)#no auto-summary

R1#clear ip route *

R2配置命令:

R2(config)#router eigrp 52                

R2(config-router)#no auto-summary

R2#clear ip route *

R3配置命令:

R3(config)#router eigrp 52                

R3(config-router)#no auto-summary

R3#clear ip route *

 

此时查看每个路由器路由表,有什么变化 ?

关闭自动汇总后路由条目中将所有的10.52.0.0网段的条目都显示出来了

问题3如果此时在R1上ping 10.62.4.1能否ping通?

      答:ping得通

 

9、 在路由器R1和R3上配置手动汇总

参考命令:

R1(config)#int f0/0

R1(config-if)#ip summary-address eigrp 52 10.52.0.0 255.255.0.0

R3(config)#int f0/1

R3(config-if)#ip summary-address eigrp 52 10.62.0.0 255.255.0.0

问题4查看各路由器路由表,有什么不同

     答:R1路由表中10.62.0.0网段都汇总成了16位的网络地址

R3路由表中10.52.0.0网段都汇总成了16位的网络地址

10、配置默认网络

在R3上配置静态路由

R3(config)#ip route 0.0.0.0 0.0.0.0 211.67.188.2

在R3上声明默认网络

R3(config)#router eigrp 52            

R3(config-router)#network 211.67.188.0

R3(config)#ip default-network 211.67.188.0

 

问题5各路由器上查看路由表,看有什么变化?

      答:配置完默认路由,在查看路由表发现多了一条默认路由

10、修改R1的f0/0接口的K值为k1=1,k2=1,k3=1,k4=0,k5=1

R1(config)#router eigrp 52                

R1(config-router)# metric weights 0 1 1 1 0 1

问题6修改后查看路由器R1和R2的邻居关系是否存在?这说明了什么?

答:K值通过EIGRPhello包运载,如果两个路由器的K值不匹配的话它们是不会形成邻居关系的

猜你喜欢

转载自blog.csdn.net/qq_42103479/article/details/89134538
0条评论
添加一条新回复