路由交换与技术eigrp实验4

实验目的:

          1、学会实验出错时排查。

          2、掌握eigrp协议的配置。

          3、掌握路由器的基本命令配置。

          4、熟练掌握GNS3软件的配置方法。

          5、进一步理解网络配置的基本原理。

 

实验拓扑:

A+9nUOgs5TxrAAAAAElFTkSuQmCC

1、配置每台路由器的IP地址,并且使用ping命令测试直连接口的互通性

R1配置命令:

R1(config-if)#interface f0/0

R1(config-if)#ip address  192.52.1.2 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#interface f0/1                     

R1(config-if)#ip address  192.52.3.1 255.255.255.0

R1(config-if)#no shuhtdown

R1(config-if)#interface Loopback0                  

R1(config-if)#ip address  192.52.4.1 255.255.255.0

R1(config-if)#end

R2配置命令:

R2(config-if)#interface f0/0

R2(config-if)#ip address 192.52.2.2  255.255.255.0  

R2(config-if)#no shutdown

R2(config-if)#interface f0/1                     

R2(config-if)#ip address 192.52.1.1  255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#interface Loopback0                  

R2(config-if)#ip address 192.52.5.1  255.255.255.0

R2(config-if)#end

R3配置命令:

R3(config)#interface f0/0

R3(config-if)#ip address 192.52.3.2 255.255.255.0

R3(config-if)#no shutdown                   

R3(config-if)#interface f0/1

R3(config-if)#ip address 192.52.2.1 255.255.255.0

R3(config-if)#no shutdown                         

R3(config-if)#interface Loopback0

R3(config-if)#ip address 192.52.6.1 255.255.255.0

R3(config-if)#end

测试直连接口通信:

R2pingR1的f0/0显示已通:

+Cb2N1Ho7VwAAAAASUVORK5CYII=

R3pingR2的f0/0显示已通:

B8HyyGRzRjKQAAAAAElFTkSuQmCC

2、在每个路由器上配置eigrp协议

R1配置命令:

R1(config)#router eigrp 52

R1(config-router)#network 192.52.1.0

R1(config-router)#network 192.52.3.0

R1(config-router)#network 192.52.4.0

R2配置命令:

R2(config)#router eigrp 52

R2(config-router)#network 192.52.1.0

R2(config-router)#network 192.52.2.0

R2(config-router)#network 192.52.5.0

R3配置命令:

R3(config)#router eigrp 52

R3(config-router)#network 192.52.2.0

R3(config-router)#network 192.52.3.0

R3(config-router)#network 192.52.6.0

 

问题一:在R1上查看路由表,到达哪个网络的路由实现了负载均衡,是等价的还是不等价的,为什么?

答:到192.52.2.0/24网络的路由实现了负载均衡,通过观察其metric值可发现其是等价的负载均衡,因为选用都是快速以太口,带宽和延迟都一样,所以其metric值计算时都相同。

H9mBrMgcWkAVwAAAABJRU5ErkJggg==

问题二:在R1中查看拓扑表,看到达网络192.52.6.0的AD和FD是多少,在R2中查看拓扑表,到达网络192.52.6.0的AD和FD是多少?

     答:在R1种查看拓扑表,到达网络192.52.6.0的AD是128256,FD是156169;

         在R2中查看拓扑表,到达网络192.52.6.0的AD是128256,FD是156169;

A0uVoXiQfj7tAAAAAElFTkSuQmCC

9LPeBUSrDQwAAAABJRU5ErkJggg==

 

3、为了实现负载均衡,修改R2f0/0接口的带宽为200Mbps,针对网络192.52.6.0,让R2成为R1的可行后继路由

R2配置命令:

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#inter f0/0

R2(config-if)#bandwidth 200000

R2(config-if)#

问题3在R1中查看拓扑表,看到达网络192.52.6.0的AD和FD是多少?在R2中查看拓扑表,看到达网络192.52.6.0的AD和FD是多少?

      答:此时经过修改R2的带宽,R1到达网络192.52.6.0的AD是128256,FD是156160

                                 R2到达网络192.52.6.0的AD是12856,FD是143360

YhMIdEAABEAABEAABEACBNgT+P+8CwUbaJQhZAAAAAElFTkSuQmCC

x9sjG4Fl8FuAQAAAABJRU5ErkJggg==

问题4通过对问题2和问题3的对比,哪些发生了变化?

      答:经过修改R2的f0/0接口带宽,R1去往192.52.6.0的拓扑中多出一条可行后继路由192.52.1.1即从R2走,R2本身的FD值经过修改带宽也发生了变化。

问题5 在R1查看拓扑表,看到达网络192.52.6.0的路径有几条?每条的AD和FD是多少?

      答:在R1中查看拓扑表,到达192.52.6.0的路径有两条,

后继路由的AD是128256,FD是156160;

          可行后继路由的AD是143360,FD是158720;

YhMIdEAABEAABEAABEACBNgT+P+8CwUbaJQhZAAAAAElFTkSuQmCC

 

 

 

问题6为了实现不等价负载均衡,应该在R1中修改variance值为多少?

     答:variance的值默认是1,代表等价路由的负载均衡,variance的取值范围是1~1281以外的值代表不等价链路的度量值的倍数。若某条路由的度量值小于此variance的值乘于FD的值即可行距离,则也将这条不等价的路由放入到路由表中即表明度量值在这个范围内的链路都将被接受)

现在如果为了实现不等价负载均衡,应该拿着可行后继路由的FD值除于AD值,即158720/143360≈1.11,所以应在R1中修改的variance应为大于1.11的整数2。

 

4、为了实现不等价负载均衡,在R1中修改variance

R1配置命令:

R1#

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#router eigrp 52

R1(config-router)#var

R1(config-router)#variance 2 

R1(config-router)#

问题7查看路由表,在路由条目192.52.6.0中有什么变化?

     答:经过修改variance值,刚才的可行后继路由已经变成了不等价负载均衡路由出现在R1的192.52.6.0条目中,实现了不等价负载均衡。

j+8QXJT546cAgAAAABJRU5ErkJggg==

 

 

5、在R1R2之间配置认证,和Rip的认证类似

R1配置命令:

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#key chain xcu

R1(config-keychain)#key 1

R1(config-keychain-key)#key

R1(config-keychain-key)#key-string  zhijiabin

R1(config-keychain-key)#interface f0/0

R1(config-if)#ip au

R1(config-if)#ip authen

R1(config-if)#ip authentication  mode eigrp 52  md5

R1(config-if)#

*Mar 31 11:56:23.315: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.1 (FastEthernet0/0) is down: authentication mode changed

R1(config-if)#ip authe

R1(config-if)#ip authentication  key-

R1(config-if)#ip authentication  key-chain  eigrp 52 xcu

R1(config-if)#shutdown                           //此处为了让路由器重新生成路由表

R1(config-if)#no shutdown

R1(config-if)#

*Mar 31 11:59:09.059: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.1 (FastEthernet0/0) is up: new adjacency

R1(config-if)#

*Mar 31 11:59:24.859: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.1 (FastEthernet0/0) is down: peer restarted

R1(config-if)#

*Mar 31 11:59:27.407: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.1 (FastEthernet0/0) is up: new adjacency

R1(config-if)#

问题8此时在R1中查看路由表到达网络192.52.6.0的下一条,是否还是192.52.1.1?为什么?

答:此时查看路由表,到达网络192.52.6.0的下一条已经变成了192.52.3.2,因为前边在R1的f0/0上做了身份认证,而R2并没有做身份认证,所以无法通过此路由传送数据包,所以路由条目中才会没有此条路由。

lnw4NRW5TAAAAAElFTkSuQmCC

6、在R2上同样做出身份认证

R2配置命令:

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#key chain xcu

R2(config-keychain)#key 1

R2(config-keychain-key)#key-

R2(config-keychain-key)#key-string  zhijiabin

R2(config-keychain-key)#interface f0/1

R2(config-if)# ip authen

R2(config-if)# ip authentication  mode eigrp 52 md5

R2(config-if)#ip authen

R2(config-if)#ip authentication key

R2(config-if)#ip authentication key-chain eigrp 52 xcu

R2(config-if)#shutdow                                 //让其重新生成路由表

*Mar 31 11:59:09.127: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.2 (FastEthernet0/1) is up: new adjacency

R2(config-if)#shutdown

R2(config-if)#n

*Mar 31 11:59:13.695: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.2 (FastEthernet0/1) is down: interface down

R2(config-if)#no shutdown

R2(config-if)#

*Mar 31 11:59:21.287: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

*Mar 31 11:59:22.287: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R2(config-if)#

*Mar 31 11:59:22.879: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.2 (FastEthernet0/1) is up: new adjacency

R2(config-if)#

问题9配置后查看R1的路由表,到达目标网络192.52.5.0的下一跳是什么?为什么?

     答:配置完身份认证查看路由表,到达目标网络192.52.5.0的下一跳是192.52.1.1,由未认证之前的192.52.3.2变成了192.52.1.1,因为R1和R2实现了身份认证,而从R2到达192.52.5.0的花费代价显然要比从R3走花费代价要小。

wM1lcVyQC4ldgAAAABJRU5ErkJggg==

 

7、将路由器R1修改为stub网络

一、概念

通过命令把远程路由器配置成Stub路由器,Stub路由器会向所有邻居发送信息告之自已的状态,其他路由器将不会向Stub路由器发送查询。

二、配置

router ei  52

eigrp stub  [option] (默认通告直连connected&汇总summary

三、stub命令的参数介绍:

eigrp stub connected     #通告直连路由

eigrp stub summary       #通告汇总路由

eigrp stub redistributed #通告重分布的路由

eigrp stub static        #通告静态路由

eigrp stub receive-only  #只接收不通告

eigrp stub leak-map      #路由泄露

四、查看stub

sh ip eigrp neighbor detail

 

R1配置命令:

R1(config)#router eigrp 52

R1(config-router)#eigrp stub rece

R1(config-router)#eigrp stub receive-only

R1(config-router)#

*Mar 31 12:24:16.023: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.1 (FastEthernet0/0) is down: peer info changed

*Mar 31 12:24:16.035: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.3.2 (FastEthernet0/1) is down: peer info changed

*Mar 31 12:24:17.603: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.3.2 (FastEthernet0/1) is up: new adjacency

*Mar 31 12:24:19.683: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 52: Neighbor 192.52.1.1 (FastEthernet0/0) is up: new adjacency

问题10配置后,在R2和R3上还能否看到192.52.4.0网段的路由?为什么?

      答:配置后,在R2和R3上将不能看到192.52.4.0网段的路由,因为配置时已将R1的状态修改为只接受其他邻居路由器传来的更新路由条目,它自己本身并不会向其他邻居路由器发送路由条目。

KoV2P+KPAoAAAAABJRU5ErkJggg==

HNc3GENCIAACIAACIAACJwggXmEnicIHiaDAAiAAAiAAAiAwOkRQOh5em0Oi0EABEAABEAABEBgTwQQeu4JPMSCAAiAAAiAAAiAwOkRQOh5em0Oi0EABEAABEAABEBgTwQQeu4JPMSCAAiAAAiAAAiAwOkRQOh5em0Oi0EABEAABEAABEBgTwQQeu4JPMSCAAiAAAiAAAiAwOkRQOh5em0Oi0EABEAABEAABEBgTwT+DzmPmx89ibrHAAAAAElFTkSuQmCC

猜你喜欢

转载自blog.csdn.net/qq_42103479/article/details/89134663
0条评论
添加一条新回复